summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rodriguez2015-09-11 09:41:44 -0400
committerDavid Rodriguez2015-09-11 09:41:44 -0400
commit31aafb9079f8dfcbb6272521c299ef2d3e46dbb5 (patch)
tree95586301ae009fff9ddd043228de83fa831aa5a0
downloadaur-31aafb9079f8dfcbb6272521c299ef2d3e46dbb5.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rw-r--r--autosshfs.install17
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..734cb816f680
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = autosshfs-git
+ pkgdesc = Per user SSHFS automount using user's SSH configuration
+ pkgver = c9dc8cd
+ pkgrel = 1
+ url = https://github.com/hellekin/autosshfs
+ install = autosshfs.install
+ arch = any
+ license = AGPL
+ makedepends = git
+ depends = autofs
+ depends = keychain
+ depends = sshfs
+ depends = x11-ssh-askpass
+ source = autosshfs-git::git://github.com/hellekin/autosshfs.git
+ md5sums = SKIP
+
+pkgname = autosshfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6b956d09d35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Carlos Franke <carlos_franke at lemtank dot de>
+
+pkgname=autosshfs-git
+_gitname=$pkgname
+pkgver=c9dc8cd
+pkgrel=1
+pkgdesc="Per user SSHFS automount using user's SSH configuration"
+arch=('any')
+url="https://github.com/hellekin/autosshfs"
+license=('AGPL')
+depends=('autofs' 'keychain' 'sshfs' 'x11-ssh-askpass')
+makedepends=('git')
+install="autosshfs.install"
+#source=("$_gitname::git://github.com/korakinos/autosshfs.git")
+source=("$_gitname::git://github.com/hellekin/autosshfs.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $_gitname/src
+ PREFIX="/usr" make -e
+}
+
+package() {
+ cd $_gitname
+ PREFIX="${pkgdir}/usr"
+ mkdir -p ${PREFIX}/bin/ ${PREFIX}/share/doc/autosshfs/
+ install -D -o root -g root -m 0750 src/autosshfs-user ${PREFIX}/bin/
+ install -D -o root -g root -m 0750 src/autosshfs-map ${PREFIX}/bin/ #group will be changed to autosshfs in install file
+ install -D -o root -g root -m 0750 src/autosshfs-ssh ${PREFIX}/bin/ #group will be changed to autosshfs in install file
+ install -D -o root -g root -m 0755 bin/keychain-ring ${PREFIX}/bin/
+ install -D -o root -g root -m 0755 -d ${PREFIX}/share/doc/autosshfs/
+ install -D -o root -g root -m 0644 doc/* ${PREFIX}/share/doc/autosshfs
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/autosshfs.install b/autosshfs.install
new file mode 100644
index 000000000000..4b1be1782525
--- /dev/null
+++ b/autosshfs.install
@@ -0,0 +1,17 @@
+PREFIX="/usr"
+
+post_install() {
+ /usr/bin/groupadd --system autosshfs # 2>/dev/null
+ /usr/bin/chgrp autosshfs ${PREFIX}/bin/autosshfs-map
+ /usr/bin/chgrp autosshfs ${PREFIX}/bin/autosshfs-ssh
+}
+
+post_upgrade() {
+ /usr/bin/chgrp autosshfs ${PREFIX}/bin/autosshfs-map
+ /usr/bin/chgrp autosshfs ${PREFIX}/bin/autosshfs-ssh
+}
+
+post_remove() {
+ /usr/bin/rm -rf $PREFIX/bin/autosshfs-* $PREFIX/bin/autosshfs-as-* $PREFIX/bin/keychain-ring $PREFIX/share/doc/autosshfs
+ /usr/bin/groupdel autosshfs
+}