summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoris Bera2015-10-25 17:27:24 -0400
committerBoris Bera2015-10-25 17:27:24 -0400
commit57e21a26d8f08f291855bc03809691c57881e239 (patch)
tree64bac32536952ffba4c7a8eb32c486067ababa1f
downloadaur-57e21a26d8f08f291855bc03809691c57881e239.tar.gz
Added first pkgbuild
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..466358b8aa75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = autotags
+ pkgdesc = A little tool that watches your source code and generates ctags.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/beraboris/autotags
+ arch = any
+ license = MIT
+ depends = bash
+ depends = ctags
+ depends = inotify-tools
+ source = https://github.com/beraboris/autotags/archive/v0.1.0.tar.gz
+ md5sums = 8db192b30309e789763ef371c37941ef
+
+pkgname = autotags
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..17ac5abc4ae3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe5672f5a4d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Boris Bera <bboris at rsoft dot ca>
+pkgname=autotags
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A little tool that watches your source code and generates ctags."
+arch=('any')
+url="https://github.com/beraboris/autotags"
+license=('MIT')
+groups=()
+depends=(bash ctags inotify-tools)
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "https://github.com/beraboris/autotags/archive/v$pkgver.tar.gz"
+)
+noextract=()
+md5sums=('8db192b30309e789763ef371c37941ef')
+
+package() {
+ install -D -m 755 "$srcdir/$pkgname-$pkgver/autotags" \
+ "$pkgdir/usr/bin"
+ install -D -m644 "$srcdir/$pkgname-$pkgver/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}