summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2020-07-20 23:52:21 +0200
committerpiotr2020-07-20 23:52:21 +0200
commit3dfe4c6560dd5c21d87db6747e69b8a8719244c6 (patch)
tree7991904ee0f4cda06fe7bac679e52c4587312a98
parent328f95402a32a1d5a147aa73d7141c70e6cf0752 (diff)
downloadaur-3dfe4c6560dd5c21d87db6747e69b8a8719244c6.tar.gz
update to 1.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49fabc75c7ed..6af20d788536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = autotiling
pkgdesc = Script for sway and i3 to automatically switch the horizontal / vertical window split orientation
- pkgver = 1.0
+ pkgver = 1.1
pkgrel = 1
url = https://github.com/nwg-piotr/autotiling
arch = x86_64
license = GPL3
+ makedepends = python-setuptools
depends = python-i3ipc
- source = https://github.com/nwg-piotr/autotiling/archive/v1.0.tar.gz
- md5sums = 2e917b570b544263184123dcea7a5b14
+ source = https://github.com/nwg-piotr/autotiling/archive/v1.1.tar.gz
+ md5sums = a42f55005bfcf631d6429fbdfc9d5b2b
pkgname = autotiling
diff --git a/PKGBUILD b/PKGBUILD
index 403997eefab4..d4d5978b82e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('autotiling')
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="Script for sway and i3 to automatically switch the horizontal / vertical window split orientation"
arch=('x86_64')
url="https://github.com/nwg-piotr/autotiling"
license=('GPL3')
depends=('python-i3ipc')
-
+makedepends=('python-setuptools')
source=("https://github.com/nwg-piotr/autotiling/archive/v"$pkgver".tar.gz")
-md5sums=('2e917b570b544263184123dcea7a5b14')
+md5sums=('a42f55005bfcf631d6429fbdfc9d5b2b')
package() {
- install -D -t "$pkgdir"/usr/lib/"$pkgname" "$pkgname"-"$pkgver"/autotiling.py
- install -D -t "$pkgdir"/usr/bin "$pkgname"-"$pkgver"/autotiling
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}