summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2019-09-25 03:43:29 +0200
committerpiotr2019-09-25 03:43:29 +0200
commit7dc82e6465e104ffaf6db49c3c1fd22e20a49ceb (patch)
treea8c4349c24a012562651cbbbe7836b407a47aa40
downloadaur-7dc82e6465e104ffaf6db49c3c1fd22e20a49ceb.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de211799f848
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = autotiling
+ pkgdesc = Script for sway and i3 to automatically switch the horizontal / vertical window split orientation
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/nwg-piotr/autotiling
+ arch = x86_64
+ license = GPL3
+ depends = python-i3ipc
+ source = https://github.com/nwg-piotr/autotiling/archive/v0.2.tar.gz
+ md5sums = 49106a623882cda9c387e39027094b1d
+
+pkgname = autotiling
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bfb4dfd9e12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
+pkgname=('autotiling')
+pkgver=0.2
+pkgrel=1
+pkgdesc="Script for sway and i3 to automatically switch the horizontal / vertical window split orientation"
+arch=('x86_64')
+url="https://github.com/nwg-piotr/autotiling"
+license=('GPL3')
+depends=('python-i3ipc')
+
+source=("https://github.com/nwg-piotr/autotiling/archive/v0.2.tar.gz")
+
+md5sums=('49106a623882cda9c387e39027094b1d')
+
+package() {
+ install -D -t "$pkgdir"/usr/lib/"$pkgname" "$pkgname"-"$pkgver"/autotiling.py
+ install -D -t "$pkgdir"/usr/bin "$pkgname"-"$pkgver"/autotiling
+}
+