summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiotr2020-08-23 13:03:29 +0200
committerpiotr2020-08-23 13:03:29 +0200
commitec33e876a692dd36330982facb9852731df6920f (patch)
treedf3f7c46d634176e67d9a9fc6c3e32562e463f6a
parentfa78e0affe9322f89ed07fb8b092874b00e3f655 (diff)
downloadaur-ec33e876a692dd36330982facb9852731df6920f.tar.gz
installation method altered
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8143877981c6..4feaecdff06d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = autotiling-git
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = python-setuptools
depends = python-i3ipc
provides = autotiling
conflicts = autotiling
diff --git a/PKGBUILD b/PKGBUILD
index 64678ec27b4f..c6c1af8e9579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Jason Nader <jason.nader@protonmail.com>
+# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('autotiling-git')
_pkgname=autotiling
pkgver=r24.6854508
@@ -8,7 +9,7 @@ arch=('x86_64')
url="https://github.com/nwg-piotr/autotiling"
license=('GPL3')
depends=('python-i3ipc')
-makedepends=('git')
+makedepends=('git' 'python-setuptools')
source=("${pkgname%-*}::git+https://github.com/nwg-piotr/autotiling.git")
md5sums=('SKIP')
provides=("autotiling")
@@ -21,7 +22,6 @@ pkgver() {
package() {
cd "$_pkgname"
- install -D -t "$pkgdir/usr/lib/$_pkgname" autotiling.py
- install -D -t "$pkgdir/usr/bin" autotiling
+ python setup.py install --root="${pkgdir}" --optimize=1
}