summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdarch2015-09-15 16:47:31 +0200
committerjdarch2015-09-15 16:47:31 +0200
commitd5607c867ac0547890d705c28ff6a16ab382952f (patch)
tree0e36afbe5d3c0904b13c50af6e349eb63d6c41fc
parent78d34aebe1366def067a54947e86ef8f7e4004c0 (diff)
downloadaur-d5607c867ac0547890d705c28ff6a16ab382952f.tar.gz
Move to new PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD52
-rw-r--r--PKGBUILD.proposal_might_need_work_for_pstoedit40
-rw-r--r--build-fixes.patch169
-rw-r--r--libpng-1.5.patch68
5 files changed, 27 insertions, 313 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f46e6a703872..d5704937d6c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autotrace
pkgdesc = An utility to trace bitmaps: convert bitmaps to vector graphics
pkgver = 0.31.1
- pkgrel = 13
+ pkgrel = 14
url = http://autotrace.sourceforge.net/
arch = i686
arch = x86_64
@@ -9,15 +9,14 @@ pkgbase = autotrace
license = LGPL
makedepends = pkg-config
makedepends = autoconf
- depends = pstoedit
depends = imagemagick>=6.5.3.10
options = !libtool
source = http://downloads.sourceforge.net/autotrace/autotrace-0.31.1.tar.gz
- source = build-fixes.patch
- source = libpng-1.5.patch
+ source = complete.patch
md5sums = 54eabbb38d2076ded6d271e1ee4d0783
- md5sums = 7ff7b76e3a2c722863e00e1ee4a55386
- md5sums = 55881b817aeae6b3bd6dfca9b2320ca3
+ md5sums = 60cdd0d29d7ab79b71b9b6e579a82b6a
+ sha512sums = 7d0ec86a41617b3d4336eed72f2974c10f569ff53d450a4c91b4611bb6fdb8c4ff81d04d91e9d20f1b4df592f82c8421e7656af7fa2bdc786ffb4618e9eadd24
+ sha512sums = 92c984a6d7bea6b58ce3fc8419d89af9c52d2029e91b0fe3e29f05f10b18d75742abff828cec551a4e8da44a22c563e321fcd91ceb3a186c040cf465fef77b97
pkgname = autotrace
diff --git a/PKGBUILD b/PKGBUILD
index a4523498c57f..5d693697a6d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
# Contributor: forest76 <forestt@poczta.onet.pl>
# Contributor: Tilman Blumenbach <tilman@ax86.net>
@@ -5,45 +6,36 @@
pkgname=autotrace
pkgver=0.31.1
-pkgrel=13
+pkgrel=14
pkgdesc='An utility to trace bitmaps: convert bitmaps to vector graphics'
arch=('i686' 'x86_64')
url='http://autotrace.sourceforge.net/'
license=('GPL' 'LGPL')
-depends=('pstoedit' 'imagemagick>=6.5.3.10')
+depends=('imagemagick>=6.5.3.10')
makedepends=('pkg-config' 'autoconf')
options=('!libtool')
-source=(http://downloads.sourceforge.net/autotrace/$pkgname-$pkgver.tar.gz
- build-fixes.patch
- libpng-1.5.patch)
-
-build() {
- _configure_args='--prefix=/usr'
- if [ `/usr/bin/pacman -Q pstoedit | cut -d ' ' -f 2` = '3.50-3' ]; then
- # This version of the pstoedit package is broken (FS #19221).
- warning \
- 'Broken pstoedit package found, disabling pstoedit support in AutoTrace.'
- _configure_args="${_configure_args} --without-pstoedit"
- fi
+source=("http://downloads.sourceforge.net/autotrace/$pkgname-$pkgver.tar.gz"
+ "complete.patch")
+md5sums=('54eabbb38d2076ded6d271e1ee4d0783'
+ '60cdd0d29d7ab79b71b9b6e579a82b6a')
+sha512sums=('7d0ec86a41617b3d4336eed72f2974c10f569ff53d450a4c91b4611bb6fdb8c4ff81d04d91e9d20f1b4df592f82c8421e7656af7fa2bdc786ffb4618e9eadd24'
+ '92c984a6d7bea6b58ce3fc8419d89af9c52d2029e91b0fe3e29f05f10b18d75742abff828cec551a4e8da44a22c563e321fcd91ceb3a186c040cf465fef77b97')
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np 1 -i "${srcdir}/build-fixes.patch"
- patch -Np 0 -i "${srcdir}/libpng-1.5.patch"
+prepare(){
+ cd autotrace-0.31.1
+ patch < ../complete.patch
+ autoreconf -ivf
+}
- autoreconf -fi
- ./configure ${_configure_args}
-
- # Thanks goes to haawda at this point
- sed -i '320s+@LIBPNG_LDFLAGS@+-lpng16+' Makefile
-
- make
+build() {
+ cd autotrace-0.31.1
+ ./configure --prefix=/usr --with-pstoedit
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make "DESTDIR=${pkgdir}" install
+ cd autotrace-0.31.1
+ make install DESTDIR="${pkgdir}"
}
-
-md5sums=('54eabbb38d2076ded6d271e1ee4d0783'
- '7ff7b76e3a2c722863e00e1ee4a55386'
- '55881b817aeae6b3bd6dfca9b2320ca3')
diff --git a/PKGBUILD.proposal_might_need_work_for_pstoedit b/PKGBUILD.proposal_might_need_work_for_pstoedit
deleted file mode 100644
index 326346e4218a..000000000000
--- a/PKGBUILD.proposal_might_need_work_for_pstoedit
+++ /dev/null
@@ -1,40 +0,0 @@
-# Maintainer: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
-# Contributor: forest76 <forestt@poczta.onet.pl>
-# Contributor: Tilman Blumenbach <tilman@ax86.net>
-# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
-
-pkgname=autotrace
-pkgver=0.31.1
-pkgrel=13
-pkgdesc='An utility to trace bitmaps: convert bitmaps to vector graphics'
-arch=('i686' 'x86_64')
-url='http://autotrace.sourceforge.net/'
-license=('GPL' 'LGPL')
-depends=('pstoedit' 'imagemagick>=6.5.3.10')
-makedepends=('pkg-config' 'autoconf')
-options=('!libtool')
-source=("http://downloads.sourceforge.net/autotrace/$pkgname-$pkgver.tar.gz"
- "complete.patch")
-md5sums=('54eabbb38d2076ded6d271e1ee4d0783'
- '60cdd0d29d7ab79b71b9b6e579a82b6a')
-sha512sums=('7d0ec86a41617b3d4336eed72f2974c10f569ff53d450a4c91b4611bb6fdb8c4ff81d04d91e9d20f1b4df592f82c8421e7656af7fa2bdc786ffb4618e9eadd24'
- '92c984a6d7bea6b58ce3fc8419d89af9c52d2029e91b0fe3e29f05f10b18d75742abff828cec551a4e8da44a22c563e321fcd91ceb3a186c040cf465fef77b97')
-
-prepare(){
- cd autotrace-0.31.1
- patch < ../complete.patch
- autoreconf -ivf
-}
-
-build() {
- cd autotrace-0.31.1
- ./configure --prefix=/usr
- sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
- sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
- make
-}
-
-package() {
- cd autotrace-0.31.1
- make install DESTDIR="${pkgdir}"
-}
diff --git a/build-fixes.patch b/build-fixes.patch
deleted file mode 100644
index 3f02e23c9d1c..000000000000
--- a/build-fixes.patch
+++ /dev/null
@@ -1,169 +0,0 @@
-diff -ruNa autotrace-0.31.1.orig/autotrace.m4 autotrace-0.31.1/autotrace.m4
---- autotrace-0.31.1.orig/autotrace.m4 2002-10-10 22:44:12.000000000 +0200
-+++ autotrace-0.31.1/autotrace.m4 2013-01-25 18:25:55.928256266 +0100
-@@ -4,7 +4,7 @@
- dnl AM_PATH_AUTOTRACE([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
- dnl Test to see if libautotrace is installed, and define AUTOTRACE_CFLAGS, LIBS
- dnl
--AC_DEFUN(AM_PATH_AUTOTRACE,
-+AC_DEFUN([AM_PATH_AUTOTRACE],
- [dnl
- dnl Get the cflags and libraries from the autotrace-config script
- dnl
-@@ -157,4 +157,4 @@
- AC_SUBST(AUTOTRACE_CFLAGS)
- AC_SUBST(AUTOTRACE_LIBS)
- rm -f conf.autotracetest
--])
-\ Kein Zeilenumbruch am Dateiende.
-+])
-diff -ruNa autotrace-0.31.1.orig/configure.in autotrace-0.31.1/configure.in
---- autotrace-0.31.1.orig/configure.in 2002-11-08 18:49:23.000000000 +0100
-+++ autotrace-0.31.1/configure.in 2013-01-25 18:27:36.973566225 +0100
-@@ -34,7 +34,7 @@
-
- AM_MAINTAINER_MODE
-
--AM_CONFIG_HEADER(config.h)
-+AC_CONFIG_HEADERS([config.h])
-
- AC_PROG_CPP
- AC_PROG_RANLIB
-@@ -43,6 +43,7 @@
- AM_SANITY_CHECK
- AC_PROG_INSTALL
- AC_CHECK_HEADERS(malloc.h)
-+PKG_PROG_PKG_CONFIG
-
- dnl
- dnl ImageMagick
-@@ -72,15 +73,20 @@
- MAGICK_VERSION=`Magick-config --version`
- changequote(,)dnl
- MAGICK_MAJOR_VERSION=`echo $MAGICK_VERSION \
-- | sed -e 's/^\([0-9]*\).[0-9]*.[0-9]*$/\1/'`
-+ | sed -e 's/^\([0-9]*\)\.[0-9]*\.[0-9]*.*$/\1/'`
- MAGICK_MINOR_VERSION=`echo $MAGICK_VERSION \
-- | sed -e 's/^[0-9]*.\([0-9]*\).[0-9]*$/\1/'`
-+ | sed -e 's/^[0-9]*\.\([0-9]*\)\.[0-9]*.*$/\1/'`
- MAGICK_MICRO_VERSION=`echo $MAGICK_VERSION \
-- | sed -e 's/^[0-9]*.[0-9]*.\([0-9]*\)$/\1/'`
-+ | sed -e 's/^[0-9]*\.[0-9]*\.\([0-9]*\).*$/\1/'`
- changequote([,])dnl
-- MAGICK_MAJOR_VERSION_CHECK=`expr $MAGICK_MAJOR_VERSION \>= 5`
-- MAGICK_MINOR_VERSION_CHECK=`expr $MAGICK_MINOR_VERSION \>= 2`
-- dnl I don't consider ImageMagick 6.x.
-+ MAGICK_MAJOR_VERSION_CHECK=`expr $MAGICK_MAJOR_VERSION '>=' 5`
-+ if test $MAGICK_MAJOR_VERSION -gt 5; then
-+ # We don't need to check the minor version.
-+ MAGICK_MINOR_VERSION_CHECK=1
-+ else
-+ MAGICK_MINOR_VERSION_CHECK=`expr $MAGICK_MINOR_VERSION '>=' 2`
-+ fi
-+
- if test "$MAGICK_VERSION" = "5.2.0" \
- || test "$MAGICK_MAJOR_VERSION_CHECK" = 0 \
- || test "$MAGICK_MINOR_VERSION_CHECK" = 0 ; then
-@@ -250,88 +256,41 @@
- dnl pstoedit library
- dnl
- HAVE_LIBPSTOEDIT=no
--HAVE_LIBPSTOEDIT_320=no
--HAVE_LIBPSTOEDIT_321=no
- LIBPSTOEDIT_CFLAGS=
- LIBPSTOEDIT_LIBS=
--LIBPSTOEDIT_EXTRA_LIBS=
-
- AC_ARG_WITH(pstoedit,
- [ --with-pstoedit link with pstoedit library(default)
- --without-pstoedit link without pstoedit library],,with_pstoedit=yes)
-+
- if test "x${with_pstoedit}" = xyes; then
--dnl
--dnl
--dnl
--AC_PROG_CXX
--dnl Standard C++ library and C++ Runtime
--dnl --- WORKAROUND for pstoedit 3.32.0
--CXX_RUNTIME_LIB=
--CXX_STD_LIB=
--if test x"$GXX" = xyes; then
-- AC_CHECK_LIB(g++,main,CXX_RUNTIME_LIB=-lg++)
-- AC_CHECK_LIB(stdc++,main,CXX_STD_LIB=-lstdc++,,${CXX_RUNTIME_LIB})
--fi
--AC_MSG_CHECKING([for C++ runtime])
--LIBPSTOEDIT_EXTRA_LIBS="${CXX_STD_LIB} ${CXX_RUNTIME_LIB}"
--AC_MSG_RESULT([${CXX_STD_LIB} ${CXX_RUNTIME_LIB}])
--dnl dl library
--dnl --- WORKAROUND for pstoedit 3.32.0
--LIBLD_LDFLAGS=
--AC_CHECK_LIB(dl,main,[LIBLD_LDFLAGS=-ldl])
--if test "x${LIBLD_LDFLAGS}" != x; then
-- LIBPSTOEDIT_EXTRA_LIBS="${LIBPSTOEDIT_EXTRA_LIBS} ${LIBLD_LDFLAGS}"
--fi
-+ PKG_CHECK_MODULES( [LIBPSTOEDIT], [pstoedit], HAVE_LIBPSTOEDIT=yes )
-
--echo '*** Checking pstoedit existence TWICE(if needed) ***'
--echo '*** This is the 1st check ***'
--AM_PATH_PSTOEDIT(3.32.1,HAVE_LIBPSTOEDIT_321=yes)
--if test ${HAVE_LIBPSTOEDIT_321} != yes; then
-- echo '*** The 1st check is failed. ***'
-- LIBS_BAKCUP=$LIBS
-- LIBS="$LIBS ${LIBPSTOEDIT_EXTRA_LIBS}"
-- echo '*** This is the 2nd check ***'
-- AM_PATH_PSTOEDIT(3.32.0,HAVE_LIBPSTOEDIT_320=yes)
-- LIBS=${LIBS_BAKCUP}
--
-- if test ${HAVE_LIBPSTOEDIT_320} = yes; then
-- echo '*** The 2nd check is passed. ***'
-- HAVE_LIBPSTOEDIT=yes
-+ if test ${HAVE_LIBPSTOEDIT} = yes; then
- AC_DEFINE(HAVE_LIBPSTOEDIT)
-- LIBPSTOEDIT_LIBS="${PSTOEDIT_LIBS} ${LIBPSTOEDIT_EXTRA_LIBS}"
-- LIBPSTOEDIT_CFLAGS="${PSTOEDIT_CFLAGS}"
-- else
-- echo '*** The 2nd check is failed. ***'
-- fi
--else
-- echo '*** The 1st check is passed. ***'
-- HAVE_LIBPSTOEDIT=yes
-- AC_DEFINE(HAVE_LIBPSTOEDIT)
-- LIBPSTOEDIT_LIBS="${PSTOEDIT_LIBS} ${LIBPSTOEDIT_EXTRA_LIBS}"
-- LIBPSTOEDIT_CFLAGS="${PSTOEDIT_CFLAGS}"
--fi
--
--if test ${HAVE_LIBPSTOEDIT} = yes; then
- AC_CHECK_FUNCS([mkstemp])
-+
- echo '*** pstoedit output functions are enabled. ***'
- echo '*** However, these are experimental functions in autotrace. ***'
- echo '*** If you get an error in building time about pstoedit, ***'
- echo '*** you can run configure with --without-pstoedit option again. ***'
--else
-+ else
- AC_MSG_WARN([
--*** Cannot find libpstoedit. ***
--*** Output functions using libpstoedit are disabled ***])
--fi
--dnl
--dnl
--dnl
-+ *** Cannot find libpstoedit. ***
-+ *** Output functions using libpstoedit are disabled ***])
-+ fi
-+ dnl
-+ dnl
-+ dnl
- else
--AC_MSG_WARN([pstoedit output functions are disabled from command line.])
-+ AC_MSG_WARN([pstoedit output functions are disabled from command line.])
- fi
-+
- AC_SUBST(LIBPSTOEDIT_CFLAGS)
- AC_SUBST(LIBPSTOEDIT_LIBS)
- AM_CONDITIONAL(HAVE_LIBPSTOEDIT, test x$HAVE_LIBPSTOEDIT = xyes)
-
-+
- dnl
- dnl Vender's cc(not gcc)
- dnl
diff --git a/libpng-1.5.patch b/libpng-1.5.patch
deleted file mode 100644
index c42deb6105df..000000000000
--- a/libpng-1.5.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-Downloaded for Arch Linux package from:
-http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-gfx/autotrace/files/autotrace-0.31.1-libpng-1.5.patch?revision=1.1
-
-More information on this patch:
-http://sourceforge.net/mailarchive/forum.php?thread_name=01e601cbc22e%24f45d7200%24dd185600%24%40acm.org&forum_name=png-mng-implement
-
-$NetBSD$
-
-Fix build with png-1.5.
-
---- input-png.c.orig 2002-10-10 20:44:14.000000000 +0000
-+++ input-png.c
-@@ -42,17 +42,17 @@ static png_bytep * read_png(png_structp
-
- static void handle_warning(png_structp png, const at_string message) {
- LOG1("PNG warning: %s", message);
-- at_exception_warning((at_exception_type *)png->error_ptr,
-+ at_exception_warning((at_exception_type *)png_get_error_ptr(png),
- message);
-- /* at_exception_fatal((at_exception_type *)at_png->error_ptr,
-+ /* at_exception_fatal((at_exception_type *)png_get_error_ptr(at_png),
- "PNG warning"); */
- }
-
- static void handle_error(png_structp png, const at_string message) {
- LOG1("PNG error: %s", message);
-- at_exception_fatal((at_exception_type *)png->error_ptr,
-+ at_exception_fatal((at_exception_type *)png_get_error_ptr(png),
- message);
-- /* at_exception_fatal((at_exception_type *)at_png->error_ptr,
-+ /* at_exception_fatal((at_exception_type *)png_get_error_ptr(at_png),
- "PNG error"); */
-
- }
-@@ -157,8 +157,8 @@ read_png(png_structp png_ptr, png_infop
-
- png_set_strip_16(png_ptr);
- png_set_packing(png_ptr);
-- if ((png_ptr->bit_depth < 8) ||
-- (png_ptr->color_type == PNG_COLOR_TYPE_PALETTE) ||
-+ if ((png_get_bit_depth(png_ptr, info_ptr) < 8) ||
-+ (png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_PALETTE) ||
- (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)))
- png_set_expand(png_ptr);
-
-@@ -181,20 +181,10 @@ read_png(png_structp png_ptr, png_infop
- PNG_BACKGROUND_GAMMA_FILE, 1, 1.0);
- } else
- png_set_strip_alpha(png_ptr);
-+ png_set_interlace_handling(png_ptr);
- png_read_update_info(png_ptr, info_ptr);
-
--
-- info_ptr->row_pointers = (png_bytepp)png_malloc(png_ptr,
-- info_ptr->height * sizeof(png_bytep));
--#ifdef PNG_FREE_ME_SUPPORTED
-- info_ptr->free_me |= PNG_FREE_ROWS;
--#endif
-- for (row = 0; row < (int)info_ptr->height; row++)
-- info_ptr->row_pointers[row] = (png_bytep)png_malloc(png_ptr,
-- png_get_rowbytes(png_ptr, info_ptr));
--
-- png_read_image(png_ptr, info_ptr->row_pointers);
-- info_ptr->valid |= PNG_INFO_IDAT;
-+ png_read_png(png_ptr, info_ptr, PNG_TRANSFORM_IDENTITY, NULL);
- png_read_end(png_ptr, info_ptr);
- return png_get_rows(png_ptr, info_ptr);
- }