summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmac892022-07-25 08:31:58 -0600
committersmac892022-07-25 08:31:58 -0600
commit2f236f7a436f8c94770348cfac41e0dc0a30b006 (patch)
tree2ba009f2d87369d374341d7b38e869870fdc81b5
downloadaur-2f236f7a436f8c94770348cfac41e0dc0a30b006.tar.gz
create autotrace-bin
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c58ab02a919b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = autotrace-bin
+ pkgdesc = AutoTrace is a utility for converting bitmap into vector graphics.
+ pkgver = 0.40.0_20200219
+ pkgrel = 1
+ url = https://github.com/autotrace/autotrace.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ depends = libpng
+ depends = pstoedit
+ depends = libmagick6
+ depends = glib2
+ provides = autotrace
+ conflicts = autotrace-git
+ source = https://github.com/autotrace/autotrace/releases/download/travis-20200219.65/autotrace_0.40.0-20200219_all.deb
+ sha512sums = c0e49c213fca78079ae02bec44fa04707d2358ddc2a5e77d6e29e1ae47028d1b7f45d604acd0d47c28320e1217278780e61d122e5383a13675e9a8cf3b136bfc
+
+pkgname = autotrace-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa9b451a0e2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: FirstAirBender <noblechuk5 [at] web [dot] de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
+# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
+# Contributor: forest76 <forestt@poczta.onet.pl>
+# Contributor: Tilman Blumenbach <tilman@ax86.net>
+# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
+
+_pkgname=autotrace
+pkgname="${_pkgname}-bin"
+_date='20200219'
+_revision='65'
+_pkgver="0.40.0-$_date"
+pkgver="${_pkgver/-/_}"
+pkgrel=1
+pkgdesc='AutoTrace is a utility for converting bitmap into vector graphics.'
+arch=('i686' 'x86_64')
+url='https://github.com/autotrace/autotrace.git'
+license=('GPL' 'LGPL')
+depends=('libpng' 'pstoedit' 'libmagick6' 'glib2')
+provides=(autotrace)
+conflicts=(autotrace-git)
+source=("https://github.com/autotrace/autotrace/releases/download/travis-$_date.$_revision/${_pkgname}_${_pkgver}_all.deb")
+sha512sums=('c0e49c213fca78079ae02bec44fa04707d2358ddc2a5e77d6e29e1ae47028d1b7f45d604acd0d47c28320e1217278780e61d122e5383a13675e9a8cf3b136bfc')
+
+package() {
+ cd "$srcdir"
+ tar -xf data.tar.xz -C ${pkgdir}
+}