summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFirstAirBender2023-07-31 18:38:21 -0600
committerFirstAirBender2023-07-31 18:38:21 -0600
commitc0036da82b13ef9d0f1a564c687d29aaa101ae3d (patch)
treee537c3c367aa5d495014f3740b18e05485bf475a
parentf5f6adc5b7fe3dae73605dab03e44ab9a285bf34 (diff)
downloadaur-c0036da82b13ef9d0f1a564c687d29aaa101ae3d.tar.gz
add comments about what I did
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7213173b04cb..60c310bec0ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = autotrace-bin
pkgdesc = AutoTrace is a utility for converting bitmap into vector graphics.
pkgver = 0.40.0_20200219
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/autotrace/autotrace.git
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b533d3105da9..bad89eebb4a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
_pkgname=autotrace
-pkgname="${_pkgname}-bin"
_date='20200219'
_revision='65'
_pkgver="0.40.0-$_date"
+pkgname="${_pkgname}-bin"
pkgver="${_pkgver/-/_}"
-pkgrel=2
+pkgrel=3
pkgdesc='AutoTrace is a utility for converting bitmap into vector graphics.'
arch=('i686' 'x86_64')
url='https://github.com/autotrace/autotrace.git'
@@ -23,6 +23,7 @@ source=("https://github.com/autotrace/autotrace/releases/download/travis-$_date.
sha256sums=('14afaed3d872f19879f3805dbb52a4721206828542068fb035e962ee2b65aedc')
package() {
+ msg2 'extract compiled binary...'
tar -xf data.tar.xz -C ${pkgdir}
msg2 'patching binary...'
@@ -32,6 +33,8 @@ package() {
LIB_NAME="$(pkg-config --variable libname MagickCore)"
# patch the binary
+ # libMagickCore-6.Q16.so.2 is the name of the imagemagick library bundled with autotrace
patchelf --replace-needed libMagickCore-6.Q16.so.2 "lib${LIB_NAME}.so" ${pkgdir}/usr/bin/autotrace
+ # libpng12.so.0 is not needed because libpng16.so.0 is also included
patchelf --remove-needed libpng12.so.0 ${pkgdir}/usr/bin/autotrace
}