summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Knaust2017-03-12 17:02:50 +0100
committerMarius Knaust2017-03-12 17:02:50 +0100
commit430e490ba6aa4dfc715d598ee90f29069a32fbde (patch)
treedb4a37d34a562710f578bd09198b106210a85235
parent3d80671394cca9dc3ed4b27ea896ac0ee874081c (diff)
downloadaur-430e490ba6aa4dfc715d598ee90f29069a32fbde.tar.gz
Enable timer after installation
-rw-r--r--PKGBUILD1
-rw-r--r--autoupdate.install7
2 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 467382d908c1..fddf09aa8901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@ pkgdesc="Download packages to update automatically."
arch=('any')
url="https://aur.archlinux.org/packages/autoupdate/"
license=('GPL')
+install=autoupdate.install
source=(autoupdate.service
autoupdate.timer)
md5sums=('315777ea88d1ca6be7a934844a48c399'
diff --git a/autoupdate.install b/autoupdate.install
new file mode 100644
index 000000000000..a381fd55ba19
--- /dev/null
+++ b/autoupdate.install
@@ -0,0 +1,7 @@
+post_install() {
+ systemctl enable autoupdate.timer
+}
+
+pre_remove() {
+ systemctl disable autoupdate.timer
+}