summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Klimenko2020-12-14 21:38:07 +0200
committerMaxim Klimenko2020-12-14 21:38:07 +0200
commit4ca93d99c7da850737a920df8f7c322f91dbebfb (patch)
tree3361de4202f72c76e57ff3a915efe2053dd8de54
parente0d8f0a97dfa0b2cc0ddf7373c243378f9204bfa (diff)
downloadaur-4ca93d99c7da850737a920df8f7c322f91dbebfb.tar.gz
Changed repository link
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75d335efc201..9b4a514bc866 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = autovpn-git
+pkgbase = autovpn
pkgdesc = Easily connect to a VPN in a country of your choice.
- pkgver = 17.4e19a80
+ pkgver = r20.a2d4278
pkgrel = 1
- url = https://github.com/adtac/autovpn
+ url = https://github.com/scry3r/autovpn.git
arch = x86_64
license = GPL3
makedepends = git
@@ -12,8 +12,7 @@ pkgbase = autovpn-git
conflicts = autovpn
options = !strip
options = !emptydirs
- source = git+https://github.com/adtac/autovpn.git
+ source = git+https://github.com/scry3r/autovpn.git
sha256sums = SKIP
-pkgname = autovpn-git
-
+pkgname = autovpn
diff --git a/PKGBUILD b/PKGBUILD
index e91c8e143dc3..e535054f55aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,29 @@
# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Maintainer: Maxim Klimenko <ghosyintheshell@gmail.com>
_pkgname=autovpn
pkgname=${_pkgname}-git
-pkgver=17.4e19a80
+pkgver=r20.a2d4278
pkgrel=1
pkgdesc='Easily connect to a VPN in a country of your choice.'
arch=('x86_64')
-url='https://github.com/adtac/autovpn'
-license=('GPL3')
+url="https://github.com/scry3r/autovpn.git"
+license=('GPL')
depends=('openvpn')
-makedepends=('git' 'go-pie')
-conflicts=('autovpn')
-provides=('autovpn')
-options=('!strip' '!emptydirs')
-source=('git+https://github.com/adtac/autovpn.git')
-sha256sums=('SKIP')
+makedepends=('go' 'go-pie')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=('git+https://github.com/scry3r/autovpn.git')
+md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}"
- go build -o ${_pkgname}
+ cd "$srcdir/${_pkgname}"
+ go build -o ${_pkgname}
}
package() {