summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-11 00:21:46 -0500
committerLuis Martinez2021-08-11 00:27:35 -0500
commit41fe9d17ea5a22f48057454dacb4950ed3eea84b (patch)
tree1bace0d365c2aa1e66ab8a721eea70b4549c1dcf
parent993c228c613759f270302bce93be81abc6522f3c (diff)
downloadaur-41fe9d17ea5a22f48057454dacb4950ed3eea84b.tar.gz
fix PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--001-Makefile.patch46
-rw-r--r--CHANGES85
-rw-r--r--PKGBUILD68
4 files changed, 165 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0db45ae219e4..5863cfa5a510 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = autozen
- pkgdesc = A binural brainwave generator. Cause the user to experience an altered state of consciousness. Wear headphones. Don't use if you suffer for any kind of epilepsy and use at your own risk!
+ pkgdesc = A binaural brainwave generator
pkgver = 2.1
- pkgrel = 3
- url = http://www.linuxlabs.com/autozen.shtml
- arch = i686
+ pkgrel = 4
+ url = http://linuxlabs.com/autozen.html
+ changelog = CHANGES
arch = x86_64
license = GPL
depends = gtk
- source = http://www.sourcefiles.org/Miscellaneous/autozen-2.1.tar.gz
- md5sums = 8d85f8435f3733b9ea835cd0ffd106cc
+ depends = perl
+ source = autozen-2.1.tar.gz::http://linuxlabs.com/download/autozen-2.1.tar.gz
+ source = 001-Makefile.patch
+ sha256sums = e7677d8b192999d02c5e25354e0546f08a933d594b79f55bfec199de947a1301
+ sha256sums = 3b48ef8e274eac0c54667d6cd009a96091dc9be842de0e1c7013194b69ff03f1
pkgname = autozen
-
diff --git a/001-Makefile.patch b/001-Makefile.patch
new file mode 100644
index 000000000000..404fe2416438
--- /dev/null
+++ b/001-Makefile.patch
@@ -0,0 +1,46 @@
+2,3c2,3
+< CC = gcc
+< CFLAGS = -g
+---
+> CC ?= gcc
+> CFLAGS ?= -g
+6,7c6,9
+< PREFIX = /usr
+< PUBLIC_SEQUENCES = $(PREFIX)/share/AutoZen
+---
+> PREFIX ?= /usr
+> DESTDIR ?=
+> LDFLAGS ?=
+> PUBLIC_SEQUENCES = $(PREFIX)/share/autozen
+9c11
+< # uncomment one of the OS= lines below if you're compiling on one of those OSen.
+---
+> # uncomment one of the OS= lines below if you're compiling on one of those OSen.
+22c24
+< $(CC) $(OS) -D_REENTRANT -DPUBLIC_SEQUENCES='"$(PUBLIC_SEQUENCES)"' $(CFLAGS) `gtk-config --cflags` `gtk-config --libs` -pthread autozen.c -o autozen $(DEBUG_LIBS)
+---
+> $(CC) $(OS) -D_REENTRANT -DPUBLIC_SEQUENCES='"$(PUBLIC_SEQUENCES)"' $(CFLAGS) `gtk-config --cflags` `gtk-config --libs` -pthread autozen.c -o autozen $(DEBUG_LIBS) $(LDFLAGS)
+25,26c27,28
+< $(CC) seq2wav.c -o seq2wav -lm
+< clean:
+---
+> $(CC) seq2wav.c -o seq2wav -lm $(CFLAGS) $(LDFLAGS)
+> clean:
+30,40c32,36
+< install -d $(PREFIX)/bin
+< install zentime $(PREFIX)/bin
+< install -s seq2wav $(PREFIX)/bin
+< install -s autozen $(PREFIX)/bin
+< install -d $(PREFIX)/share/AutoZen
+< install -m 644 *.seq $(PREFIX)/share/AutoZen
+< install -d $(PREFIX)/share/doc/AutoZen/HTML/images
+< install -m 644 doc/HTML/*.html $(PREFIX)/share/doc/AutoZen/HTML
+< install -m 644 doc/HTML/images/* $(PREFIX)/share/doc/AutoZen/HTML/images
+< install -d $(PREFIX)/man/man1
+< install -m 644 doc/autozen.1 $(PREFIX)/man/man1
+---
+> install -Dm 755 zentime seq2wav -t "$(DESTDIR)/$(PREFIX)/bin/"
+> install -Dm 644 *.seq -t "$(DESTDIR)/$(PUBLIC_SEQUENCES)/"
+> install -Dm 644 doc/HTML/*.html -t "$(DESTDIR)/$(PUBLIC_SEQUENCES)/HTML/"
+> install -Dm 644 doc/HTML/images/* -t "$(DESTDIR)/$(PUBLIC_SEQUENCES)/HTML/images/"
+> install -Dm 644 doc/autozen.1 -t "$(DESTDIR)/$(PREFIX)/share/man/man1/"
diff --git a/CHANGES b/CHANGES
new file mode 100644
index 000000000000..30a438749cf2
--- /dev/null
+++ b/CHANGES
@@ -0,0 +1,85 @@
+2.1
+ Added ability to specify number of harmonics on command line.
+
+ Added HARMONICS command to AutoZen and seq2wav.
+
+ A VOLUME command at the beginning of a sequence is now processed before AutoZen
+ starts producing sound.
+
+ Autozen now looks in ~/.autozen and /usr/share/AutoZen for sequence files when
+ the play button is presed. the ~/.autozen directory is created if it doesn't
+ exist.
+
+ Added install to Makefile.
+
+ The source tar has been fully debianized.
+
+2.0
+ Added -colorbox option
+ The colorbox is a simple window which oscillates between red and green
+ in synch with the audio phase difference. Hopefully, the color change
+ will inject a second autozen signal into the visual cortex.
+
+ When the colorbox is active, a phase adjustment slide is provided at the
+ bottom of the main Autozen window. A phase adjust is necessary since I don't
+ know the time delay difference between the auditory and visual signal paths
+ and it may, in fact, be different for each individual. The strongest
+ entrainment should be achieved by adjusting the phase control so that the
+ auditory and visual signals arrive simultainiously in the midbrain. Other
+ interesting effects may be achievable by detuning the phase from that setting
+ to create an interference pattern in the brain (thus stimulating only some areas).
+ Not much is known about that yet, so please keep logs of experiments in that area.
+
+ At user request, the max beat frequency is now 40 Hz.
+
+ Code cleanup (again).
+ Window creation has been moved into seperate functions to enhance readability.
+ A few other small fixes made.
+ A few more things are #defines now.
+
+1.3
+ Minor appearance and readability cleanups for GUI.
+
+ Added sequencer commands for seq2wav to control volume fade
+ when producing wav files.
+
+ Added EXIT sequencer command to cause AutoZen to fade volume and
+ quit rather than continuing at the final beat frequency when a
+ sequence ends.
+
+ Added time.pl, a simple script to total up how long a sequence file
+ will play for.
+
+ Should compile for Solaris and *BSD by uncommenting a line in Makefile
+ Thanks to Trevor Johnson for this.
+
+ Added a debian sub-directory to facilitate making a .deb.
+
+1.2.1
+
+ A small but important bug in the sound generation function.
+ When it's too early, (2^i) looks like it should do pow(2,i) :-)
+
+1.2
+
+ Much improved effectiveness. It now uses several upper harmonics of
+ the tones with the same phase relation as the base frequency.
+
+ Fade in/out. Audio is now faded in when AutoZen is started, and
+ fades back out when Quit is pressed. Press Quit twice to exit instantly.
+ Play button graphic now changes based on state. Now displays vertical
+ bars when playing a sequence and a yellow triangle when a sequence is
+ paused.
+
+ More code cleanup. Factored sound generation into logical functions.
+
+ Generalized sound functions so that harmonics can be easily mixed in
+ with the base frequency.
+
+ Added seq2wav.
+
+1.1
+ Internal version, not released.
+
+1.0
+ This is the initial public release.
diff --git a/PKGBUILD b/PKGBUILD
index 07b3738fe188..17164a984b1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,32 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Harvie
-# Maintainer: realitygaps
+# Contributor: realitygaps
+
pkgname=autozen
pkgver=2.1
-pkgrel=3
-pkgdesc="A binural brainwave generator. Cause the user to experience an altered state of consciousness. Wear headphones. Don't use if you suffer for any kind of epilepsy and use at your own risk!"
-url="http://www.linuxlabs.com/autozen.shtml"
-license="GPL"
-arch=('i686' 'x86_64')
-source=(http://www.sourcefiles.org/Miscellaneous/$pkgname-$pkgver.tar.gz)
-depends=('gtk')
-md5sums=('8d85f8435f3733b9ea835cd0ffd106cc')
-
-build() {
-#Make
-cd ${srcdir}/${pkgname}-${pkgver}/ || return 1
-make clean || return 1
-make || return 1
-
-mkdir -p ${pkgdir}/usr/
-make "PREFIX=${pkgdir}/usr" install || return 1
+pkgrel=4
+pkgdesc="A binaural brainwave generator"
+arch=('x86_64')
+url="http://linuxlabs.com/autozen.html"
+license=('GPL')
+depends=('gtk' 'perl')
+changelog=CHANGES
+source=("$pkgname-$pkgver.tar.gz::http://linuxlabs.com/download/$pkgname-$pkgver.tar.gz"
+ '001-Makefile.patch')
+sha256sums=('e7677d8b192999d02c5e25354e0546f08a933d594b79f55bfec199de947a1301'
+ '3b48ef8e274eac0c54667d6cd009a96091dc9be842de0e1c7013194b69ff03f1')
-#Menu Icons
-mkdir -p ${pkgdir}/usr/share/applications/
-
-echo '[Desktop Entry]
-Encoding=UTF-8
-Name=AutoZen
-GenericName=BrainWave Generator/Synchronizator
-Exec=autozen
-Icon=autozen
-Categories=Application;GTK;AudioVideo;Player;
-Terminal=false
-Type=Application
-' > ${pkgdir}/usr/share/applications/autozen.desktop
+prepare() {
+ patch -p1 -d "$pkgname-$pkgver" Makefile < 001-Makefile.patch
+}
-echo '[Desktop Entry]
-Encoding=UTF-8
-Name=AutoZen (colorbox)
-GenericName=BrainWave Generator/Synchronizator
-Exec=autozen -colorbox
-Icon=autozen
-Categories=Application;GTK;AudioVideo;Player;
-Terminal=false
-Type=Application
-' > ${pkgdir}/usr/share/applications/autozen-colorbox.desktop
+build() {
+ cd "$pkgname-$pkgver"
+ make clean
+ make PREFIX=/usr
+}
-#Rights
-chmod -R 755 ${pkgdir}
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}