summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrealitygaps2015-07-06 16:49:59 +0200
committerrealitygaps2015-07-06 16:49:59 +0200
commit993c228c613759f270302bce93be81abc6522f3c (patch)
treeb81079aa0f00b1513327494579d43b50f61ecfb4
downloadaur-993c228c613759f270302bce93be81abc6522f3c.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0db45ae219e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = autozen
+ pkgdesc = A binural brainwave generator. Cause the user to experience an altered state of consciousness. Wear headphones. Don't use if you suffer for any kind of epilepsy and use at your own risk!
+ pkgver = 2.1
+ pkgrel = 3
+ url = http://www.linuxlabs.com/autozen.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk
+ source = http://www.sourcefiles.org/Miscellaneous/autozen-2.1.tar.gz
+ md5sums = 8d85f8435f3733b9ea835cd0ffd106cc
+
+pkgname = autozen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07b3738fe188
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Harvie
+# Maintainer: realitygaps
+pkgname=autozen
+pkgver=2.1
+pkgrel=3
+pkgdesc="A binural brainwave generator. Cause the user to experience an altered state of consciousness. Wear headphones. Don't use if you suffer for any kind of epilepsy and use at your own risk!"
+url="http://www.linuxlabs.com/autozen.shtml"
+license="GPL"
+arch=('i686' 'x86_64')
+source=(http://www.sourcefiles.org/Miscellaneous/$pkgname-$pkgver.tar.gz)
+depends=('gtk')
+md5sums=('8d85f8435f3733b9ea835cd0ffd106cc')
+
+build() {
+#Make
+cd ${srcdir}/${pkgname}-${pkgver}/ || return 1
+make clean || return 1
+make || return 1
+
+mkdir -p ${pkgdir}/usr/
+make "PREFIX=${pkgdir}/usr" install || return 1
+
+#Menu Icons
+mkdir -p ${pkgdir}/usr/share/applications/
+
+echo '[Desktop Entry]
+Encoding=UTF-8
+Name=AutoZen
+GenericName=BrainWave Generator/Synchronizator
+Exec=autozen
+Icon=autozen
+Categories=Application;GTK;AudioVideo;Player;
+Terminal=false
+Type=Application
+' > ${pkgdir}/usr/share/applications/autozen.desktop
+
+echo '[Desktop Entry]
+Encoding=UTF-8
+Name=AutoZen (colorbox)
+GenericName=BrainWave Generator/Synchronizator
+Exec=autozen -colorbox
+Icon=autozen
+Categories=Application;GTK;AudioVideo;Player;
+Terminal=false
+Type=Application
+' > ${pkgdir}/usr/share/applications/autozen-colorbox.desktop
+
+#Rights
+chmod -R 755 ${pkgdir}
+}