summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-06-18 05:18:42 -0600
committerBrian Bidulock2015-06-10 04:06:36 -0600
commitc93c6466deb2e29c42082572cb510cf7f4004336 (patch)
tree4bbd7c5ad914d58c848600117500a9b17c083f24
parenta4747d4b6e5d875617bcbe892b999fcf9f47ade1 (diff)
downloadaur-c93c6466deb2e29c42082572cb510cf7f4004336.tar.gz
version 0.6.31-12
-rw-r--r--.AURINFO46
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
3 files changed, 56 insertions, 12 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 00000000000..005c54f4259
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,46 @@
+pkgbase = avahi-gtk2
+ pkgdesc = Multicast/unicast DNS-SD framework (with Gtk2 client apps)
+ pkgver = 0.6.31
+ pkgrel = 12
+ url = http://www.avahi.org/
+ install = install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = qt4
+ makedepends = pygtk
+ makedepends = intltool
+ makedepends = python2-dbus
+ makedepends = gobject-introspection
+ makedepends = gtk2
+ makedepends = xmltoman
+ depends = expat
+ depends = libdaemon
+ depends = glib2
+ depends = libcap
+ depends = gdbm
+ depends = dbus
+ optdepends = gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings
+ optdepends = qt4: qt4 bindings
+ optdepends = pygtk: avahi-bookmarks, avahi-discover
+ optdepends = twisted: avahi-bookmarks
+ optdepends = python2-dbus: avahi-discover
+ optdepends = nss-mdns: NSS support for mDNS
+ provides = avahi=0.6.31
+ provides = howl
+ provides = mdnsresponder
+ conflicts = avahi
+ conflicts = howl
+ conflicts = mdnsresponder
+ replaces = avahi
+ source = http://www.avahi.org/download/avahi-0.6.31.tar.gz
+ options = !emptydirs
+ backup = etc/avahi/hosts
+ backup = etc/avahi/avahi-daemon.conf
+ backup = etc/avahi/services/ssh.service
+ backup = etc/avahi/services/sftp-ssh.service
+ backup = usr/lib/avahi/service-types.db
+ backup = usr/share/avahi/service-types
+
+pkgname = avahi-gtk2
+
diff --git a/.SRCINFO b/.SRCINFO
index b0dc4645e3f..fdd1c486fa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = avahi-gtk2
pkgdesc = Multicast/unicast DNS-SD framework (with Gtk2 client apps)
pkgver = 0.6.31
- pkgrel = 11
+ pkgrel = 12
url = http://www.avahi.org/
install = install
arch = i686
arch = x86_64
license = LGPL
- makedepends = qt3
makedepends = qt4
makedepends = pygtk
makedepends = intltool
@@ -20,9 +19,8 @@ pkgbase = avahi-gtk2
depends = glib2
depends = libcap
depends = gdbm
- optdepends = dbus: communicating with client applications
+ depends = dbus
optdepends = gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings
- optdepends = qt3: qt3 bindings
optdepends = qt4: qt4 bindings
optdepends = pygtk: avahi-bookmarks, avahi-discover
optdepends = twisted: avahi-bookmarks
diff --git a/PKGBUILD b/PKGBUILD
index 5c8c30eb903..37a222f8024 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
+# $Id: PKGBUILD 212820 2014-05-15 14:29:12Z eric $
# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
_pkgname=avahi
pkgname=avahi-gtk2
pkgver=0.6.31
-pkgrel=11
+pkgrel=12
pkgdesc='Multicast/unicast DNS-SD framework (with Gtk2 client apps)'
url='http://www.avahi.org/'
license=('LGPL')
arch=('i686' 'x86_64')
options=('!emptydirs')
-depends=('expat' 'libdaemon' 'glib2' 'libcap' 'gdbm')
+depends=('expat' 'libdaemon' 'glib2' 'libcap' 'gdbm' 'dbus')
replaces=(${_pkgname})
-optdepends=('dbus: communicating with client applications'
- 'gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings'
- 'qt3: qt3 bindings'
+optdepends=('gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings'
'qt4: qt4 bindings'
'pygtk: avahi-bookmarks, avahi-discover'
'twisted: avahi-bookmarks'
'python2-dbus: avahi-discover'
'nss-mdns: NSS support for mDNS')
-makedepends=('qt3' 'qt4' 'pygtk' 'intltool' 'python2-dbus'
+makedepends=('qt4' 'pygtk' 'intltool' 'python2-dbus'
'gobject-introspection' 'gtk2' 'xmltoman')
backup=('etc/avahi/hosts'
'etc/avahi/avahi-daemon.conf'
@@ -45,7 +46,6 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- export MOC_QT3=/usr/bin/moc-qt3
export MOC_QT4=/usr/bin/moc-qt4
export PYTHON=/usr/bin/python2
@@ -56,8 +56,8 @@ build() {
--sbindir=/usr/bin \
--disable-mono \
--disable-gtk3 \
- --disable-static \
--disable-monodoc \
+ --disable-qt3 \
--enable-compat-libdns_sd \
--enable-compat-howl \
--with-distro=archlinux \