summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-01-07 21:11:36 -0700
committerBrian Bidulock2015-06-10 04:06:37 -0600
commitd105b055b0e0bf8b44c70436b01e43cb3c988816 (patch)
tree7108173094f4183d4016c3072831aaff42038fd7
parentc93c6466deb2e29c42082572cb510cf7f4004336 (diff)
downloadaur-d105b055b0e0bf8b44c70436b01e43cb3c988816.tar.gz
version 0.6.31-14
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdd1c486fa09..f70ab82a2b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = avahi-gtk2
pkgdesc = Multicast/unicast DNS-SD framework (with Gtk2 client apps)
pkgver = 0.6.31
- pkgrel = 12
+ pkgrel = 14
url = http://www.avahi.org/
install = install
arch = i686
arch = x86_64
license = LGPL
- makedepends = qt4
- makedepends = pygtk
makedepends = intltool
- makedepends = python2-dbus
makedepends = gobject-introspection
makedepends = gtk2
makedepends = xmltoman
@@ -21,10 +18,6 @@ pkgbase = avahi-gtk2
depends = gdbm
depends = dbus
optdepends = gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings
- optdepends = qt4: qt4 bindings
- optdepends = pygtk: avahi-bookmarks, avahi-discover
- optdepends = twisted: avahi-bookmarks
- optdepends = python2-dbus: avahi-discover
optdepends = nss-mdns: NSS support for mDNS
provides = avahi=0.6.31
provides = howl
@@ -38,7 +31,6 @@ pkgbase = avahi-gtk2
backup = etc/avahi/avahi-daemon.conf
backup = etc/avahi/services/ssh.service
backup = etc/avahi/services/sftp-ssh.service
- backup = usr/lib/avahi/service-types.db
backup = usr/share/avahi/service-types
source = http://www.avahi.org/download/avahi-0.6.31.tar.gz
sha1sums = 7e05bd78572c9088b03b1207a0ad5aba38490684
diff --git a/PKGBUILD b/PKGBUILD
index 37a222f8024e..e5597442a83a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=avahi
pkgname=avahi-gtk2
pkgver=0.6.31
-pkgrel=12
+pkgrel=14
pkgdesc='Multicast/unicast DNS-SD framework (with Gtk2 client apps)'
url='http://www.avahi.org/'
license=('LGPL')
@@ -15,18 +15,12 @@ options=('!emptydirs')
depends=('expat' 'libdaemon' 'glib2' 'libcap' 'gdbm' 'dbus')
replaces=(${_pkgname})
optdepends=('gtk2: avahi-discover-standalone, bshell, bssh, bvnc, gtk2 bindings'
- 'qt4: qt4 bindings'
- 'pygtk: avahi-bookmarks, avahi-discover'
- 'twisted: avahi-bookmarks'
- 'python2-dbus: avahi-discover'
'nss-mdns: NSS support for mDNS')
-makedepends=('qt4' 'pygtk' 'intltool' 'python2-dbus'
- 'gobject-introspection' 'gtk2' 'xmltoman')
+makedepends=('intltool' 'gobject-introspection' 'gtk2' 'xmltoman')
backup=('etc/avahi/hosts'
'etc/avahi/avahi-daemon.conf'
'etc/avahi/services/ssh.service'
'etc/avahi/services/sftp-ssh.service'
- 'usr/lib/avahi/service-types.db'
'usr/share/avahi/service-types')
source=("http://www.avahi.org/download/avahi-${pkgver}.tar.gz")
sha1sums=('7e05bd78572c9088b03b1207a0ad5aba38490684')
@@ -54,10 +48,18 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--sbindir=/usr/bin \
- --disable-mono \
- --disable-gtk3 \
--disable-monodoc \
--disable-qt3 \
+ --disable-qt4 \
+ --disable-gtk3 \
+ --disable-python \
+ --disable-pygtk \
+ --disable-python-dbus \
+ --disable-mono \
+ --disable-doxygen-doc \
+ --disable-doxygen-dot \
+ --disable-doxygen-xml \
+ --disable-doxygen-html \
--enable-compat-libdns_sd \
--enable-compat-howl \
--with-distro=archlinux \
@@ -77,4 +79,7 @@ package() {
# howl and mdnsresponder compatability
cd "${pkgdir}"/usr/include; ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h; ln -s avahi-compat-howl howl
cd "${pkgdir}"/usr/lib/pkgconfig; ln -s avahi-compat-howl.pc howl.pc
+
+ # see FS#42638
+ ln avahi-daemon.service -s "${pkgdir}"/usr/lib/systemd/system/dbus-org.freedesktop.Avahi.service
}