summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2015-07-07 08:43:55 +0300
committerAlexey D2015-07-07 08:45:07 +0300
commit460a7245e12b70c84f26718627ce5baca1ed6bed (patch)
tree3f532c774be21ed030fd20fdcf1331fd8cbf44e1
parentcc1bafef239c83a7ace894f520a39a32817a6ff9 (diff)
downloadaur-460a7245e12b70c84f26718627ce5baca1ed6bed.tar.gz
version 0.6.31-2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
-rw-r--r--avahi.install12
3 files changed, 44 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fa3e2ddd12c..98f16fa29fb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = avahi-nosystemd
- pkgdesc = Multicast/unicast DNS-SD framework
+ pkgdesc = Multicast DNS-SD / Zeroconf Suite
pkgver = 0.6.31
- pkgrel = 1
+ pkgrel = 2
url = http://www.avahi.org/
install = avahi.install
arch = i686
@@ -16,6 +16,7 @@ pkgbase = avahi-nosystemd
makedepends = gobject-introspection
makedepends = gtk3
makedepends = xmltoman
+ makedepends = git
depends = expat
depends = libdaemon
depends = glib2
@@ -26,7 +27,7 @@ pkgbase = avahi-nosystemd
optdepends = gtk2: gtk2 bindings
optdepends = qt4: qt4 bindings
optdepends = pygtk: avahi-bookmarks, avahi-discover
- optdepends = twisted: avahi-bookmarks
+ optdepends = python2-twisted: avahi-bookmarks
optdepends = mono: mono bindings
optdepends = python2-dbus: avahi-discover
optdepends = nss-mdns: NSS support for mDNS
@@ -46,10 +47,12 @@ pkgbase = avahi-nosystemd
backup = etc/avahi/services/sftp-ssh.service
backup = usr/lib/avahi/service-types.db
backup = usr/share/avahi/service-types
- source = http://www.avahi.org/download/avahi-0.6.31.tar.gz
- source = rc.d.patch
- sha1sums = 7e05bd78572c9088b03b1207a0ad5aba38490684
- sha1sums = d40050547c5637e77ef51fcf11936f0724bd7844
+ source = git+https://github.com/heftig/avahi#commit=573e3b5
+ source = avahi-daemon.rc
+ source = avahi-dnsconfd.rc
+ sha1sums = SKIP
+ sha1sums = 2f580771e008ed09e9c6caf5ee0a2707a6f04ded
+ sha1sums = c14d281a023b2c3ed834a107ad1e7f13c5c7469a
pkgname = avahi-nosystemd
diff --git a/PKGBUILD b/PKGBUILD
index 376e6afd35bf..0ac7523cac4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Maintainer: Alexey D. <lq07829icatm@rambler.ru>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
pkgname=avahi-nosystemd
pkgver=0.6.31
-pkgrel=1
-pkgdesc='Multicast/unicast DNS-SD framework'
+pkgrel=2
+_commit=573e3b5
+pkgdesc='Multicast DNS-SD / Zeroconf Suite'
url='http://www.avahi.org/'
license=('LGPL')
arch=('i686' 'x86_64')
@@ -15,7 +17,7 @@ optdepends=('gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
'gtk2: gtk2 bindings'
'qt4: qt4 bindings'
'pygtk: avahi-bookmarks, avahi-discover'
- 'twisted: avahi-bookmarks'
+ 'python2-twisted: avahi-bookmarks'
'mono: mono bindings'
'python2-dbus: avahi-discover'
'nss-mdns: NSS support for mDNS')
@@ -23,32 +25,31 @@ provides=("avahi=${pkgver}" 'howl' 'mdnsresponder')
replaces=('avahi' 'howl' 'mdnsresponder')
conflicts=('avahi' 'howl' 'mdnsresponder')
makedepends=('qt4' 'pygtk' 'mono' 'intltool' 'python2-dbus'
- 'gtk-sharp-2' 'gobject-introspection' 'gtk3' 'xmltoman')
+ 'gtk-sharp-2' 'gobject-introspection' 'gtk3' 'xmltoman' 'git')
backup=('etc/avahi/hosts'
'etc/avahi/avahi-daemon.conf'
'etc/avahi/services/ssh.service'
'etc/avahi/services/sftp-ssh.service'
'usr/lib/avahi/service-types.db'
'usr/share/avahi/service-types')
-source=("http://www.avahi.org/download/avahi-${pkgver}.tar.gz"
- rc.d.patch)
-sha1sums=('7e05bd78572c9088b03b1207a0ad5aba38490684'
- 'd40050547c5637e77ef51fcf11936f0724bd7844')
+source=("git+https://github.com/heftig/avahi#commit=$_commit"
+ avahi-daemon.rc
+ avahi-dnsconfd.rc)
+sha1sums=('SKIP'
+ '2f580771e008ed09e9c6caf5ee0a2707a6f04ded'
+ 'c14d281a023b2c3ed834a107ad1e7f13c5c7469a')
install=avahi.install
prepare() {
- cd "${srcdir}/avahi-${pkgver}"
- sed '/^Libs:/s:$: -ldbus-1:' -i avahi-client.pc.in
- sed 's:netdev:network:g' -i avahi-daemon/avahi-dbus.conf
- sed 's:/sbin/resolvconf:/usr/sbin/resolvconf:g' -i */*.action
- sed 's:-DG[^ ]*_DISABLE_DEPRECATED=1::g' -i avahi-ui/Makefile.*
+ cd avahi
- patch -p1 -i ../rc.d.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "${srcdir}/avahi-${pkgver}"
+ cd avahi
+
export MOC_QT4=/usr/bin/moc-qt4
export PYTHON=/usr/bin/python2
@@ -64,17 +65,26 @@ build() {
--with-distro=archlinux \
--with-avahi-priv-access-group=network \
--with-autoipd-user=avahi \
- --with-autoipd-group=avahi \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --with-autoipd-group=avahi
+
+ cp -a avahi-python/avahi avahi-python/avahi3
make
+ make -C avahi-python/avahi3 PYTHON=/usr/bin/python3
}
package() {
- cd "${srcdir}/avahi-${pkgver}"
+ cd avahi
+
make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" -C avahi-python/avahi3 install \
+ PYTHON=/usr/bin/python3 pythondir=/usr/lib/python3.4/site-packages
# howl and mdnsresponder compatability
- cd "${pkgdir}"/usr/include; ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h; ln -s avahi-compat-howl howl
- cd "${pkgdir}"/usr/lib/pkgconfig; ln -s avahi-compat-howl.pc howl.pc
+ ln -s avahi-compat-howl "$pkgdir/usr/include/howl"
+ ln -s avahi-compat-howl.pc "$pkgdir/usr/lib/pkgconfig/howl.pc"
+
+ # install rc scripts
+ install -Dm755 "$srcdir"/avahi-daemon.rc "$pkgdir"/etc/rc.d/avahi-daemon
+ install -Dm755 "$srcdir"/avahi-dnsconfd.rc "$pkgdir"/etc/rc.d/avahi-dnsconfd
}
diff --git a/avahi.install b/avahi.install
index 2ede3a48aaa9..b6bdc30fb45f 100644
--- a/avahi.install
+++ b/avahi.install
@@ -1,6 +1,8 @@
post_install() {
- getent group avahi &>/dev/null || groupadd -r -g 84 avahi >/dev/null
- getent passwd avahi &>/dev/null || useradd -r -u 84 -g avahi -d / -s /bin/false -c avahi avahi >/dev/null
+ if ! getent passwd avahi &>/dev/null; then
+ groupadd -r -g 84 avahi
+ useradd -r -u 84 -g avahi -d / -s /bin/nologin -c avahi av
+ fi
cat <<EOF
==> The following daemons may be added to DAEMONS in /etc/rc.conf:
@@ -12,9 +14,3 @@ EOF
true
}
-
-post_remove() {
- getent passwd avahi &>/dev/null && userdel avahi >/dev/null
- getent group avahi &>/dev/null && groupdel avahi >/dev/null
- true
-}