summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2016-08-22 14:53:14 +0300
committerMantas Mikulėnas2016-08-22 14:53:21 +0300
commit61bbeb7c3cef7d86336c908d1af3c2db94c8d5bc (patch)
tree9b55c5f7f83236d6fd2c1175c91ebead83e4f003
downloadaur-avahi-static-services.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
-rw-r--r--sftp-ssh.service34
-rw-r--r--ssh.service34
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc13800e0fa1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Aug 22 11:53:18 UTC 2016
+pkgbase = avahi-static-services
+ pkgdesc = Configuration to advertise SSH & SFTP via Avahi
+ pkgver = 1
+ pkgrel = 1
+ arch = any
+ depends = avahi
+ backup = etc/avahi/services/ssh.service
+ backup = etc/avahi/services/sftp-ssh.service
+ source = ssh.service
+ source = sftp-ssh.service
+ sha256sums = 83c63e090cf20cd1bca469dc9f2b549a6972ac99c3ea8a2a5df7c10b4b537579
+ sha256sums = 60a516f94e4da95dc65d7f39494d1920a1f64ed59b88579ec5e181b9ed203353
+
+pkgname = avahi-static-services
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be1f3e23e733
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=avahi-static-services
+pkgver=1
+pkgrel=1
+pkgdesc="Configuration to advertise SSH & SFTP via Avahi"
+arch=(any)
+depends=(avahi)
+backup=(etc/avahi/services/{ssh,sftp-ssh}.service)
+source=({ssh,sftp-ssh}.service)
+sha256sums=('83c63e090cf20cd1bca469dc9f2b549a6972ac99c3ea8a2a5df7c10b4b537579'
+ '60a516f94e4da95dc65d7f39494d1920a1f64ed59b88579ec5e181b9ed203353')
+
+package() {
+ for f in *.service; do
+ install -D -m 644 "$f" "$pkgdir/etc/avahi/services/$f"
+ done
+}
+
+# vim: ts=2:sw=2:et:
diff --git a/sftp-ssh.service b/sftp-ssh.service
new file mode 100644
index 000000000000..dfae4f136639
--- /dev/null
+++ b/sftp-ssh.service
@@ -0,0 +1,34 @@
+<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
+<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
+
+<!--
+ This file is part of avahi.
+
+ avahi is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as
+ published by the Free Software Foundation; either version 2 of the
+ License, or (at your option) any later version.
+
+ avahi is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with avahi; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+ 02111-1307 USA.
+-->
+
+<!-- See avahi.service(5) for more information about this configuration file -->
+
+<service-group>
+
+ <name replace-wildcards="yes">%h</name>
+
+ <service>
+ <type>_sftp-ssh._tcp</type>
+ <port>22</port>
+ </service>
+
+</service-group>
diff --git a/ssh.service b/ssh.service
new file mode 100644
index 000000000000..c66e0c1e69f9
--- /dev/null
+++ b/ssh.service
@@ -0,0 +1,34 @@
+<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
+<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
+
+<!--
+ This file is part of avahi.
+
+ avahi is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as
+ published by the Free Software Foundation; either version 2 of the
+ License, or (at your option) any later version.
+
+ avahi is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with avahi; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+ 02111-1307 USA.
+-->
+
+<!-- See avahi.service(5) for more information about this configuration file -->
+
+<service-group>
+
+ <name replace-wildcards="yes">%h</name>
+
+ <service>
+ <type>_ssh._tcp</type>
+ <port>22</port>
+ </service>
+
+</service-group>