summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-04-27 20:23:56 +0200
committerChristopher Arndt2016-04-27 20:23:56 +0200
commitd12170ed5aba44484d572bbf75b0247fe76469a0 (patch)
tree7ad386e3d6d508b77866bfb6843554d930250e79
parent09cba3aa4d04d07908f67d0e9d782a50ca149605 (diff)
downloadaur-d12170ed5aba44484d572bbf75b0247fe76469a0.tar.gz
Fix build issues
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fccffc059d7..0821903aaf18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Apr 27 18:23:42 UTC 2016
pkgbase = avbin
pkgdesc = Cross-platform media decoding library
pkgver = 10
- pkgrel = 1
+ pkgrel = 2
url = http://avbin.github.com/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7fb3159469ca..205ef3054eee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgname=avbin
pkgver=10
-pkgrel=1
+pkgrel=2
_gittag="$pkgname-$pkgver"
+_gitsubmodule="https://github.com/AVbin/libav.git"
pkgdesc="Cross-platform media decoding library"
arch=('i686' 'x86_64')
url="http://avbin.github.com/"
@@ -20,7 +21,14 @@ sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${pkgname}"
+ if [ ! -e libav/Makefile ]; then
+ git rm libav
+ git submodule add --force ${_gitsubmodule} libav
+ fi
+
git checkout "${_gittag}"
+ cd libav
+ git checkout v9.5
}
build() {
@@ -29,8 +37,8 @@ build() {
target="linux-$(echo $CARCH | sed -e 's/_/-/')"
msg "Building target ${target}..."
# Linux Makefile uses LDFLAGS directly for ld command line
- export LDFLAGS="$(echo $LDFLAGS | sed -e 's/^-Wl//')"
- ./build.sh --fast ${target}
+ export LDFLAGS="$(echo $LDFLAGS | sed -e 's/^-Wl,//')"
+ bash -x build.sh --fast ${target}
}
package() {