summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author7452756332017-05-19 23:03:30 +0800
committer7452756332017-05-19 23:03:30 +0800
commit39030d6fd73117c00e3264f8c23e53cba2a0dd5a (patch)
treebdcfb8adb344ddfec2ae0078c2083cdb181befd1
downloadaur-39030d6fd73117c00e3264f8c23e53cba2a0dd5a.tar.gz
first
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD52
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4896814af85d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = avhttp-git
+ pkgdesc = Concurrent http downloader
+ pkgver = r887.f9d6e36
+ pkgrel = 1
+ url = http://avplayer.org/avhttp.html
+ arch = any
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ makedepends = boost
+ depends = boost-libs
+ optdepends = zlib: gzip support
+ optdepends = openssl: https support
+ provides = avhttp
+ conflicts = avhttp
+ source = git+https://github.com/avplayer/avhttp.git
+ sha256sums = SKIP
+
+pkgname = avhttp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89f98d577e9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: DATSD <dastudiodirector at gmail dot com>
+_basename=avhttp
+pkgname=${_basename}-git
+pkgver=r887.f9d6e36
+pkgrel=1
+pkgdesc='Concurrent http downloader'
+arch=('any')
+url='http://avplayer.org/avhttp.html'
+license=('custom')
+depends=('boost-libs')
+optdepends=(
+ 'zlib: gzip support'
+ 'openssl: https support'
+)
+makedepends=('cmake' 'git' 'boost')
+provides=('avhttp')
+conflicts=('avhttp')
+source=("git+https://github.com/avplayer/avhttp.git")
+sha256sums=('SKIP')
+
+pkgver()
+{
+ cd "${srcdir}/${_basename}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd "${srcdir}/${_basename}"
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir -p build && cd build
+
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" ..
+ make
+}
+
+package()
+{
+ cd "${_basename}/build"
+ make install DESTDIR="${pkgdir}/"
+
+ # Install the documentation
+ install -D -m644 "${srcdir}/${_basename}/README.md" \
+ "${pkgdir}/usr/share/doc/${_basename}/README"
+
+ # Install the license
+ install -D -m644 "${srcdir}/${_basename}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${_basename}/LICENSE"
+}