summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author7452756332017-05-30 14:52:33 +0800
committer7452756332017-05-30 14:52:33 +0800
commitae806979896b23217d751debac3ce7bc1ff11848 (patch)
treeec99832d5abc08acfc9ab06681695b2f9fe7fe90
parent39030d6fd73117c00e3264f8c23e53cba2a0dd5a (diff)
downloadaur-ae806979896b23217d751debac3ce7bc1ff11848.tar.gz
change format
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4896814af85d..e037b0d8d20d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = avhttp-git
pkgdesc = Concurrent http downloader
- pkgver = r887.f9d6e36
+ pkgver = 2.9.9.r99
pkgrel = 1
url = http://avplayer.org/avhttp.html
arch = any
license = custom
makedepends = cmake
makedepends = git
- makedepends = boost
- depends = boost-libs
+ depends = boost
optdepends = zlib: gzip support
optdepends = openssl: https support
- provides = avhttp
+ provides = avhttp=2.9.9.r99
conflicts = avhttp
- source = git+https://github.com/avplayer/avhttp.git
+ source = avhttp::git+https://github.com/avplayer/avhttp.git
sha256sums = SKIP
pkgname = avhttp-git
diff --git a/PKGBUILD b/PKGBUILD
index 89f98d577e9f..0b60f96aa724 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: DATSD <dastudiodirector at gmail dot com>
_basename=avhttp
pkgname=${_basename}-git
-pkgver=r887.f9d6e36
+pkgver=2.9.9.r99
pkgrel=1
pkgdesc='Concurrent http downloader'
arch=('any')
url='http://avplayer.org/avhttp.html'
license=('custom')
-depends=('boost-libs')
+depends=('boost')
optdepends=(
'zlib: gzip support'
'openssl: https support'
)
-makedepends=('cmake' 'git' 'boost')
-provides=('avhttp')
-conflicts=('avhttp')
-source=("git+https://github.com/avplayer/avhttp.git")
+makedepends=('cmake' 'git')
+provides=("${_basename}=${pkgver}")
+conflicts=("${_basename}")
+source=("${_basename}::git+https://github.com/avplayer/avhttp.git")
sha256sums=('SKIP')
pkgver()
{
cd "${srcdir}/${_basename}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*\)-g.*/r\1/;s/-/./g' | cut -c2-
}
build()
@@ -39,7 +39,7 @@ build()
package()
{
- cd "${_basename}/build"
+ cd "${srcdir}/${_basename}/build"
make install DESTDIR="${pkgdir}/"
# Install the documentation