summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-06-15 01:01:47 +0800
committerChocobo12019-06-15 01:06:01 +0800
commitbffa99ffde220bf57efc4958e5152afd0f6c91ad (patch)
treeb863a2e178e786243f1842dc4bd3855795b45319
parent8415bb6bdfd0459a1a744a36dcd3dfe582bd72f6 (diff)
downloadaur-bffa99ffde220bf57efc4958e5152afd0f6c91ad.tar.gz
upgpkg: avif-git 0.2.0.r3.g9c502a4-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05bd72412afd..e76c7c4e7959 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = avif-git
pkgdesc = Library for encoding and decoding .avif files
- pkgver = 0.1.3.r3.g127822c
+ pkgver = 0.2.0.r3.g9c502a4
pkgrel = 1
- url = https://github.com/joedrago/avif
+ url = https://github.com/AOMediaCodec/libavif
arch = i686
arch = x86_64
license = BSD
@@ -13,7 +13,7 @@ pkgbase = avif-git
provides = avif
conflicts = avif
options = staticlibs
- source = git+https://github.com/joedrago/avif.git
+ source = git+https://github.com/AOMediaCodec/libavif.git
sha256sums = SKIP
pkgname = avif-git
diff --git a/PKGBUILD b/PKGBUILD
index d8ccf64b44a5..9fae3d2989d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=avif-git
-pkgver=0.1.3.r3.g127822c
+pkgver=0.2.0.r3.g9c502a4
pkgrel=1
pkgdesc="Library for encoding and decoding .avif files"
arch=('i686' 'x86_64')
-url="https://github.com/joedrago/avif"
+url="https://github.com/AOMediaCodec/libavif"
license=('BSD')
depends=('glibc')
makedepends=('git' 'cmake' 'nasm')
provides=('avif')
conflicts=('avif')
options=('staticlibs')
-source=("git+https://github.com/joedrago/avif.git")
+source=("git+https://github.com/AOMediaCodec/libavif.git")
sha256sums=('SKIP')
prepare() {
- cd "avif"
+ cd "libavif"
git submodule update --init --recursive
}
pkgver() {
- cd "avif"
+ cd "libavif"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "avif"
+ cd "libavif"
mkdir -p "_build" && cd "_build"
cmake \
@@ -42,7 +42,7 @@ build() {
}
package() {
- cd "avif"
+ cd "libavif"
install -Dm755 "_build"/{avifdec,avifenc} -t "$pkgdir/usr/bin"