summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-22 22:08:08 +0100
committersL1pKn072023-01-22 22:08:08 +0100
commitb027fea87d6fda72185f0e19e8080e2c35b4ff9c (patch)
treea129fdef449367b3deea7418515c542b84f18c60
parent5eaed11616d89090d2de6c112711721e467d7bce (diff)
downloadaur-b027fea87d6fda72185f0e19e8080e2c35b4ff9c.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69b1522db302..820c59ecb811 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,9 +7,11 @@ pkgbase = avisynth-plugin-average-git
license = MIT
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-average
conflicts = avisynth-plugin-average
+ options = debug
source = average::git+https://github.com/pinterf/Average.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 49a3ba80ed2a..bb86b02be75a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,16 @@ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/pinterf/Average'
license=('MIT')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/pinterf/Average.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
@@ -31,9 +33,10 @@ prepare() {
build() {
cd build
- CXXFLAGS=" $(pkg-config --cflags avisynth)" cmake "../${_plug}" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ CXXFLAGS=" $(pkg-config --cflags avisynth)" \
+ cmake "../${_plug}" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
make
}