summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-08 23:55:08 +0200
committersL1pKn072021-10-08 23:55:08 +0200
commit6e653575964dfdeffc7fb3959d5f49cb9ec36ec4 (patch)
treec21db1b5642f313e9785c562ce0e66ca3429e0e4
downloadaur-6e653575964dfdeffc7fb3959d5f49cb9ec36ec4.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af747c2010aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avisynth-plugin-bwdif-git
+ pkgdesc = Plugin for Avisynth: bwdif (GIT version)
+ pkgver = 1.2.1.3.g3523a88
+ pkgrel = 1
+ url = https://github.com/Asd-g/AviSynth-BWDIF
+ arch = x86_64
+ license = GPL
+ license = Apache
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-bwdif
+ conflicts = avisynth-plugin-bwdif
+ source = bwdif::git+https://github.com/Asd-g/AviSynth-BWDIF.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-bwdif-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cca0a357e29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=bwdif
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=1.2.1.3.g3523a88
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Asd-g/AviSynth-BWDIF'
+license=('GPL' 'Apache')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Asd-g/AviSynth-BWDIF.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p "${_plug}/build"
+}
+
+build() {
+ cd "${_plug}/build"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+
+ install -Dm644 "${_plug}/src/VCL2/LICENSE" "${pkgdir}/usr/share/license/${_plug}/VCL2_LICENSE"
+}