summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-22 23:04:58 +0100
committersL1pKn072023-01-22 23:04:58 +0100
commitd29dbd95512c53efb1dd5f5c92b1aa14cce356b0 (patch)
treef94d5d124050dc5b65555e26d48d014c3b69d695
parentd4ed46a20d6e2b154a6ea9acef116109306eaf8f (diff)
downloadaur-avisynth-plugin-dpid-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 221d80189181..9350f6c78d7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = avisynth-plugin-dpid-git
pkgdesc = Plugin for Avisynth: dpid (GIT version)
- pkgver = 1.0.0.2.g2a13540
+ pkgver = 1.1.0.0.g8f57f3c
pkgrel = 1
url = https://github.com/Asd-g/AviSynth-DPID
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-dpid
conflicts = avisynth-plugin-dpid
+ options = debug
source = dpid::git+https://github.com/Asd-g/AviSynth-DPID.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 88ba1d628ddb..9ec3b6b8b47e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,42 @@
_plug=dpid
pkgname=avisynth-plugin-${_plug}-git
-pkgver=1.0.0.2.g2a13540
+pkgver=1.1.0.0.g8f57f3c
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/AviSynth-DPID'
license=('GPL')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/AviSynth-DPID.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p "${_plug}/build"
-}
-
build() {
- cd "${_plug}/build"
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
}