summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-06 01:10:28 +0200
committersL1pKn072021-10-06 01:10:28 +0200
commitf3cccc9c94b4e66f3d55abda771220b29955550c (patch)
tree7bca69aec29132008e42938ac7064e1ebf5f7e00
downloadaur-f3cccc9c94b4e66f3d55abda771220b29955550c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acf6013aa987
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = avisynth-plugin-frfun7-git
+ pkgdesc = Plugin for Avisynth: frfun7 (GIT version)
+ pkgver = 0.7.0.gc2b478b
+ pkgrel = 1
+ url = https://github.com/pinterf/Frfun7
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-frfun7
+ conflicts = avisynth-plugin-frfun7
+ source = frfun7::git+https://github.com/pinterf/Frfun7.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-frfun7-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c70b6d5dca94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=frfun7
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=0.7.0.gc2b478b
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/pinterf/Frfun7'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/pinterf/Frfun7.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avistnth/plugins/${_plug}/README.md"
+}