summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-04-08 23:08:13 +0200
committersL1pKn072020-04-08 23:08:13 +0200
commit75fc396fd842c5260ecc08704586466605d8288a (patch)
tree9082bdc70220a3c4bc74cf5c5f370469a21da5d5
parent8d7048d754d7f463f81f53f34732d5793d1ba0d0 (diff)
downloadaur-75fc396fd842c5260ecc08704586466605d8288a.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
-rw-r--r--avisynth.patch19
4 files changed, 5 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3df537a3331..9e2b1bdb6f48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = avisynth-plugin-lsmashsource-git
pkgdesc = Plugin for Avisynth: lsmashsource (GIT version)
- pkgver = r1036.86f757d
+ pkgver = r1042.c128310
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=167435
arch = x86_64
@@ -16,9 +16,7 @@ pkgbase = avisynth-plugin-lsmashsource-git
provides = avisynth-plugin-lsmashsource
conflicts = avisynth-plugin-lsmashsource
source = lsmashsource::git+https://github.com/HolyWu/L-SMASH-Works.git
- source = avisynth.patch
sha256sums = SKIP
- sha256sums = 0acae0a04dbb1174eab08c4c41d33fa9df0bd33463f7e09bbb9b2e2581242f6a
pkgname = avisynth-plugin-lsmashsource-git
diff --git a/.gitignore b/.gitignore
index d98e3ffdd6b0..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-!avisynth.patch
diff --git a/PKGBUILD b/PKGBUILD
index c78e1446fccc..992f0d55a679 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=lsmashsource
pkgname=avisynth-plugin-${_plug}-git
-pkgver=r1036.86f757d
+pkgver=r1042.c128310
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -20,12 +20,8 @@ makedepends=('git'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/HolyWu/L-SMASH-Works.git"
- 'avisynth.patch'
- )
-sha256sums=('SKIP'
- '0acae0a04dbb1174eab08c4c41d33fa9df0bd33463f7e09bbb9b2e2581242f6a'
- )
+source=("${_plug}::git+https://github.com/HolyWu/L-SMASH-Works.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -37,14 +33,12 @@ prepare() {
mkdir -p build
rm -fr "${_plug}/include/"{avs*,avi*}
-
- patch -d "${_plug}" -p1 -i "${srcdir}/avisynth.patch"
}
build() {
cd build
- arch-meson "../${_plug}/AviSynth"
+ meson "../${_plug}/AviSynth"
}
package(){
diff --git a/avisynth.patch b/avisynth.patch
deleted file mode 100644
index 634336fd182e..000000000000
--- a/avisynth.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/AviSynth/meson.build b/AviSynth/meson.build
-index b20c0d4..97c0255 100644
---- a/AviSynth/meson.build
-+++ b/AviSynth/meson.build
-@@ -57,6 +57,7 @@ sources = [
- includes = include_directories('../include')
-
- deps = [
-+ dependency('avisynth'),
- dependency('liblsmash'),
- dependency('libavcodec', version : '>=58.18.0'),
- dependency('libavformat', version : '>=58.12.0'),
-@@ -78,5 +79,5 @@ shared_module('lsmashsource', sources,
- include_directories : includes,
- install : true,
- install_dir : join_paths(get_option('libdir'), 'avisynth'),
-- gnu_symbol_visibility : 'hidden'
-+ gnu_symbol_visibility : 'default'
- )