summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-26 13:03:18 +0100
committersL1pKn072023-01-26 13:03:18 +0100
commitf39468be1cd75ddd4d5304451393ae5a16c26bd1 (patch)
treef35ba462c4bd2f5b55dfa110c71af91081ae3ffc
parent94dae86889826c935aab1a543ec110225330d94d (diff)
downloadaur-avisynth-plugin-rawsource26-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed7b3f972a95..f5c8513309c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = avisynth-plugin-rawsource26-git
pkgdesc = Plugin for Avisynth: rawsource26 (GIT version)
- pkgver = 1.3.1.0.gae700df
+ pkgver = 1.3.2.0.g700e7e2
pkgrel = 1
url = https://github.com/Asd-g/RawSource_2.6x
arch = x86_64
license = custom
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-rawsource26
conflicts = avisynth-plugin-rawsource26
+ options = debug
source = rawsource26::git+https://github.com/Asd-g/RawSource_2.6x.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6b7d77638b6c..c5106faea67e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,42 @@
_plug=rawsource26
pkgname=avisynth-plugin-${_plug}-git
-pkgver=1.3.1.0.gae700df
+pkgver=1.3.2.0.g700e7e2
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/RawSource_2.6x'
license=('custom')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/RawSource_2.6x.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p "${_plug}/build"
-}
-
build() {
- cd "${_plug}/build"
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
}