summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-01-07 18:37:05 +0100
committersL1pKn072021-01-07 18:37:05 +0100
commit127db062b49336e2636e99a283b4aeff032a603d (patch)
tree685e1aeb62dc4a70852c7ed2eec388742294c404
downloadaur-127db062b49336e2636e99a283b4aeff032a603d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a53ceea1955f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avisynth-plugin-rgtools-git
+ pkgdesc = Plugin for Avisynth: rgtools (GIT version)
+ pkgver = 1.1.0.g1311d1c
+ pkgrel = 1
+ url = https://github.com/pinterf/RgTools
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-rgtools
+ conflicts = avisynth-plugin-rgtools
+ source = rgtools::git+https://github.com/pinterf/RgTools.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-rgtools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e59796d8e16b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=rgtools
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=1.1.0.g1311d1c
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/pinterf/RgTools'
+license=('MIT')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/pinterf/RgTools.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/${_plug}/README.md"
+ install -Dm644 "${_plug}/RgTools/documentation/RgTools.txt" "${pkgdir}/usr/share/doc/${_plug}/RgTools.txt"
+
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}