summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSuNNjek2020-07-14 22:12:47 +0200
committerSuNNjek2020-07-14 22:12:47 +0200
commit9bc5ba01d296c096374aaa4632094d55a3c686ce (patch)
treebd5fea10f7e4101fe3b0a06d6a6850859f6c77d7
downloadaur-9bc5ba01d296c096374aaa4632094d55a3c686ce.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3075b4d0b055
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avisynth-plugin-rotate-git
+ pkgdesc = Rotate plugin for AviSynth+
+ pkgver = r3.a6e77bf
+ pkgrel = 1
+ url = https://github.com/SuNNjek/rotate-plugin
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = avisynthplus
+ provides = avisynth-plugin-rotate
+ conflicts = avisynth-plugin-rotate
+ source = avisynth-plugin-rotate::git+https://github.com/SuNNjek/rotate-plugin#branch=master
+ md5sums = SKIP
+
+pkgname = avisynth-plugin-rotate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..524339df5d77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sunner <sunnerlp at gmail dot com>
+_pkgname=avisynth-plugin-rotate
+_branch=master
+pkgname=$_pkgname-git
+pkgver=r3.a6e77bf
+pkgrel=1
+pkgdesc="Rotate plugin for AviSynth+"
+url='https://github.com/SuNNjek/rotate-plugin'
+arch=('x86_64')
+license=('GPL')
+makedepends=('git' 'cmake' 'avisynthplus')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url#branch=$_branch")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make -C "$srcdir/$_pkgname/build" DESTDIR="$pkgdir" install
+}