summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-23 00:05:55 +0100
committersL1pKn072023-01-23 00:05:55 +0100
commit95f2f7094be38d0a83095cd1c89f604284f5c20a (patch)
tree6ac777b1f0fae440cadcaaabcd2f359be7537d0b
parent5831bdd1cd8e1b26058e509f12b9dabd7e88ae84 (diff)
downloadaur-95f2f7094be38d0a83095cd1c89f604284f5c20a.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fdda8f95cb8..dfb3d9f43f1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = avisynth-plugin-smoothuv2-git
pkgdesc = Plugin for Avisynth: smoothuv2 (GIT version)
- pkgver = 4.4.0.1.g36415a3
+ pkgver = 4.4.1.0.g128f09c
pkgrel = 1
url = https://github.com/Asd-g/AviSynth-SmoothUV2
arch = x86_64
@@ -8,9 +8,11 @@ pkgbase = avisynth-plugin-smoothuv2-git
license = Apache
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-smoothuv2
conflicts = avisynth-plugin-smoothuv2
+ options = debug
source = smoothuv2::git+https://github.com/Asd-g/AviSynth-SmoothUV2.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f534983a68da..0c6e5971ee0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,42 @@
_plug=smoothuv2
pkgname=avisynth-plugin-${_plug}-git
-pkgver=4.4.0.1.g36415a3
+pkgver=4.4.1.0.g128f09c
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/AviSynth-SmoothUV2'
license=('GPL' 'Apache')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/AviSynth-SmoothUV2.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p "${_plug}/build"
-}
-
build() {
- cd "${_plug}/build"
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"