summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-01-06 18:48:31 +0100
committersL1pKn072021-01-06 18:48:31 +0100
commit143bf27f36748e86ad5865b5f61a057bb7968ba1 (patch)
tree571bcfe35d807007e4824d60c02f286391dafa67
downloadaur-143bf27f36748e86ad5865b5f61a057bb7968ba1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD56
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23b8ed4ebeaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avisynth-plugin-tivtc-git
+ pkgdesc = Plugin for Avisynth: tivtc (GIT version)
+ pkgver = r257.94eb799
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=182032
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-tivtc
+ conflicts = avisynth-plugin-tivtc
+ source = tivtc::git+https://github.com/pinterf/TIVTC.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-tivtc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed312646c09d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=tivtc
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=r257.94eb799
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=182032'
+license=('LGPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/pinterf/TIVTC.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+
+ rm -fr "${_plug}/include/"{avs*,avi*}
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}/src" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+
+# cd ..
+# g++ -fpic ${CXXLAGS} ${CPPFLAGS} -o RetreiveRanges "${_plug}/Retreive Ranges/RetrieveRanges.cpp"
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+
+# install -Dm755 RetreiveRanges "${pkgdir}/usr/bin/RetreiveRanges"
+# install -Dm644 "${_plug}/Retreive Ranges/RetrieveRanges-ReadMe.txt" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/RetrieveRanges-ReadMe.txt"
+
+ install -Dm644 "${_plug}/Doc_TDeint/tdeint.htm" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/TDeint/tdeint.htm"
+
+ for i in "${_plug}/Doc_TIVTC/"*.txt; do
+ install -Dm644 "${i}" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/TIVTC/$(basename "${i}")"
+ done
+}