summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-06 02:00:52 +0200
committersL1pKn072021-10-06 02:00:52 +0200
commitd6fef0c4f31340538460cd0d730aa995892da722 (patch)
tree0860d3815c18da53b2f9cd3fe4c569dc33fb9f0b
parente322314b677077acf5fd98ed5339ee3db9235903 (diff)
downloadaur-d6fef0c4f31340538460cd0d730aa995892da722.tar.gz
bump
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbde6bf069d8..86af3b088b62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = avisynth-plugin-tivtc-git
pkgdesc = Plugin for Avisynth: tivtc (GIT version)
- pkgver = v1.0.25.11.gaf18f2c
+ pkgver = v1.0.26.16.g9c47880
pkgrel = 1
url = https://github.com/pinterf/TIVTC
arch = x86_64
@@ -14,4 +14,3 @@ pkgbase = avisynth-plugin-tivtc-git
sha256sums = SKIP
pkgname = avisynth-plugin-tivtc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3d375d1fb1f6..6448b0fdb8c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=tivtc
pkgname=avisynth-plugin-${_plug}-git
-pkgver=v1.0.25.11.gaf18f2c
+pkgver=v1.0.26.16.g9c47880
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -25,14 +25,16 @@ pkgver() {
prepare() {
mkdir -p build
- rm -fr "${_plug}/include/"{avs*,avi*}
+ rm -fr "${_plug}/src/include/"{avs*,avi*}
}
build() {
cd build
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
+
cmake "../${_plug}/src" \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
make
@@ -52,4 +54,9 @@ package(){
for i in "${_plug}/Doc_TIVTC/"*.txt; do
install -Dm644 "${i}" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/TIVTC/$(basename "${i}")"
done
+
+ cd "${_plug}/examples/"
+ find . -type f -print0 | while read -d $'\0' i; do
+ install -Dm644 "${i}" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/examples/${i}"
+ done
}