summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-01-07 17:48:20 +0100
committersL1pKn072021-01-07 17:48:20 +0100
commitb64bb31e953a7441a5035ebcb1c92369ba295f8b (patch)
tree7796cf3fadb0c2e3f435782562df134f13a28bac
downloadaur-b64bb31e953a7441a5035ebcb1c92369ba295f8b.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD54
-rw-r--r--esee37
4 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1ef7e4a2761
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = avisynth-plugin-turnstile-git
+ pkgdesc = Plugin for Avisynth: turnstile (GIT version)
+ pkgver = v1.0.0.0.g9174d07
+ pkgrel = 1
+ url = https://github.com/ItEndsWithTens/TurnsTile
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-turnstile
+ conflicts = avisynth-plugin-turnstile
+ source = turnstile::git+https://github.com/ItEndsWithTens/TurnsTile.git
+ source = git+https://github.com/lvandeve/lodepng.git
+ source = esee
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 6c4265143c0ff198634c31f04b15a0eb232cf332cadedac8b42aa12ff91886f2
+
+pkgname = avisynth-plugin-turnstile-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fce6edeefba2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!esee
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e49fee4ddd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=turnstile
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=v1.0.0.0.g9174d07
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/ItEndsWithTens/TurnsTile'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/ItEndsWithTens/TurnsTile.git"
+ 'git+https://github.com/lvandeve/lodepng.git'
+ 'esee'
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ '6c4265143c0ff198634c31f04b15a0eb232cf332cadedac8b42aa12ff91886f2'
+ )
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+
+ cd "${_plug}"
+ patch -p1 -i "${srcdir}/esee"
+
+ git config submodule.include/lodepng.url "${srcdir}/lodepng"
+ git submodule update --init include/lodepng
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DAVISYNTHPLUS_HDR=/usr/include/avisynth/avisynth.h
+
+ make
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/esee b/esee
new file mode 100644
index 000000000000..0a46e6cd3fb2
--- /dev/null
+++ b/esee
@@ -0,0 +1,37 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1a9f277..72c8a09 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -289,12 +289,12 @@ set(CPACK_SOURCE_IGNORE_FILES
+ "zip$"
+ )
+
+-set(CMAKE_INSTALL_PREFIX ${CMAKE_SOURCE_DIR}/artifacts/install CACHE INTERNAL "")
++include(GNUInstallDirs)
+
+ install(
+ TARGETS TurnsTile
+- RUNTIME DESTINATION .
+- LIBRARY DESTINATION .
++ RUNTIME DESTINATION $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/avisynth
++ LIBRARY DESTINATION $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/avisynth
+ PERMISSIONS
+ OWNER_READ OWNER_WRITE OWNER_EXECUTE
+ GROUP_READ GROUP_EXECUTE
+@@ -313,7 +313,7 @@ endif()
+
+ install(
+ FILES README.md
+- DESTINATION .
++ DESTINATION $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}/doc/avistnth/plugins/turnstile
+ RENAME ${TURNSTILE_OUTPUT_NAME}.txt
+ )
+
+@@ -363,6 +363,6 @@ install(
+ CODE "
+ file(
+ INSTALL ${CMAKE_SOURCE_DIR}/extras
+- DESTINATION ${TURNSTILE_CPACK_TEMP_DIR})
++ DESTINATION $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}/doc/avistnth/plugins/turnstile)
+ "
+ )