summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-23 01:10:19 +0100
committersL1pKn072023-01-23 01:10:19 +0100
commitc9de0b511e2ae3c8ba1d3bc79004d58875ca963b (patch)
tree76579c2b079834bd5e85a3023e701619a1efd80c
parent3caf96016b06ff82a73b99822253ae8062b8b0b5 (diff)
downloadaur-avisynth-plugin-yadifmod2-git.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c284a76d5ed1..11964ac469e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = avisynth-plugin-yadifmod2-git
pkgdesc = Plugin for Avisynth: yadifmod2 (GIT version)
- pkgver = 0.2.7.0.g54afaf5
+ pkgver = 0.2.7.1.g0e4e2f9
pkgrel = 1
url = https://github.com/Asd-g/yadifmod2
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
- depends = avisynthplus
+ makedepends = avisynthplus
+ depends = libavisynth.so
provides = avisynth-plugin-yadifmod2
conflicts = avisynth-plugin-yadifmod2
+ options = debug
source = yadifmod2::git+https://github.com/Asd-g/yadifmod2.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7310ac0bcb5e..796fa86817bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,42 @@
_plug=yadifmod2
pkgname=avisynth-plugin-${_plug}-git
-pkgver=0.2.7.0.g54afaf5
+pkgver=0.2.7.1.g0e4e2f9
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/yadifmod2'
license=('GPL')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/yadifmod2.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p "${_plug}/build"
-}
-
build() {
- cd "${_plug}/build"
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/readme.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
}