summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-01-07 17:04:57 +0100
committersL1pKn072021-01-07 17:04:57 +0100
commit3d58ea2ce732f8e82c2e281439ab3091ea8f4058 (patch)
treeac673fe1f757564c810412446bb9dd626349875a
downloadaur-3d58ea2ce732f8e82c2e281439ab3091ea8f4058.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c2f56dccccb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avisynth-plugin-yadifmod2-git
+ pkgdesc = Plugin for Avisynth: yadifmod2 (GIT version)
+ pkgver = 0.2.6.5.ga3472ef
+ pkgrel = 1
+ url = https://github.com/Asd-g/yadifmod2
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avisynthplus
+ provides = avisynth-plugin-yadifmod2
+ conflicts = avisynth-plugin-yadifmod2
+ source = yadifmod2::git+https://github.com/Asd-g/yadifmod2.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-yadifmod2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d8f56a9e64f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=yadifmod2
+pkgname=avisynth-plugin-${_plug}-git
+pkgver=0.2.6.5.ga3472ef
+pkgrel=1
+pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Asd-g/yadifmod2'
+license=('GPL')
+depends=('avisynthplus')
+makedepends=('git'
+ 'cmake'
+ )
+provides=("avisynth-plugin-${_plug}")
+conflicts=("avisynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Asd-g/yadifmod2.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake "../${_plug}/build" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+}
+
+package(){
+ install -Dm755 build/libyadifmod2.so "${pkgdir}/usr/lib/avisynth/libyadifmod2.so"
+
+ install -Dm644 "${_plug}/readme.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/readme.md"
+}