summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM J Stanway2017-03-30 19:13:33 -0700
committerM J Stanway2017-03-30 19:13:33 -0700
commitd69585d48b793c8c507003044d835e818ffe4dd3 (patch)
treeafcb8974e3c62f51dc2c88003f2147d8f115e647
downloadaur-d69585d48b793c8c507003044d835e818ffe4dd3.tar.gz
add minimum reqired files for AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--avl.patch71
3 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6f6c057d336
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = avl
+ pkgdesc = aerodynamic and flight-dynamic analysis of rigid aircraft using an extended vortex lattice model
+ pkgver = 3.36
+ pkgrel = 1
+ url = http://web.mit.edu/drela/Public/web/avl/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = gcc-libs
+ depends = libx11
+ options = !strip
+ source = http://web.mit.edu/drela/Public/web/avl/avl3.36.tgz
+ source = avl.patch
+ md5sums = 61cf7ed7629142567ac8a9c9e1ba4981
+ md5sums = e85136557dad261f79a742b8fcdfe424
+
+pkgname = avl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59bdb87f413b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: M Jordan Stanway <bluesquall+aur-avl@gmail.com>
+pkgname=avl
+pkgver=3.36
+pkgrel=1
+pkgdesc="aerodynamic and flight-dynamic analysis of rigid aircraft using an extended vortex lattice model"
+arch=('i686' 'x86_64')
+url="http://web.mit.edu/drela/Public/web/avl/"
+license=('GPL')
+makedepends=('gcc-fortran')
+depends=('gcc-libs' 'libx11')
+options=('!strip')
+source=('http://web.mit.edu/drela/Public/web/avl/avl3.36.tgz' 'avl.patch')
+md5sums=('61cf7ed7629142567ac8a9c9e1ba4981'
+ 'e85136557dad261f79a742b8fcdfe424')
+
+prepare() {
+ cd Avl
+ patch -Np1 -i "$startdir/avl.patch"
+}
+
+build() {
+ cd Avl/plotlib
+ make gfortranDP
+
+ cd ../eispack
+ make -f Makefile.gfortran
+
+ cd ../bin
+ make -f Makefile.gfortran avl
+}
+
+package() {
+ install -d "$pkgdir/usr/bin/"
+ install -m 0755 "${srcdir}/Avl/bin/avl" "$pkgdir/usr/bin/"
+ install -d "$pkgdir/usr/share/avl/"
+ install -m 0644 "${srcdir}/Avl/README" "$pkgdir/usr/share/avl/"
+ install -m 0644 "${srcdir}/Avl/version_notes.txt" "$pkgdir/usr/share/avl/"
+ install -m 0644 "${srcdir}/Avl/avl_doc.txt" "$pkgdir/usr/share/avl/"
+ install -m 0644 "${srcdir}/Avl/session1.txt" "$pkgdir/usr/share/avl/"
+ install -m 0644 "${srcdir}/Avl/session2.txt" "$pkgdir/usr/share/avl/"
+}
diff --git a/avl.patch b/avl.patch
new file mode 100644
index 000000000000..0336043047b5
--- /dev/null
+++ b/avl.patch
@@ -0,0 +1,71 @@
+diff -ura avl.orig/bin/Makefile.gfortran avl.new/bin/Makefile.gfortran
+--- avl.orig/bin/Makefile.gfortran 2017-02-12 11:25:41.000000000 -0800
++++ avl.new/bin/Makefile.gfortran 2017-03-30 17:31:47.645245947 -0700
+@@ -66,7 +66,7 @@
+ ## Uncomment for gfortran
+ FC = gfortran
+ OPT = -O
+-DP =
++#DP =
+ ACHK =
+
+ PLTLIB = -L/usr/X11R6/lib -lX11
+@@ -77,14 +77,14 @@
+ #ACHK = -fbounds-check -finit-real=inf
+ #ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
+
+-PLTOBJ = ../plotlib/libPlt_gSP.a
+-EIGOBJ = ../eispack/libeispack.a
++#PLTOBJ = ../plotlib/libPlt_gSP.a
++#EIGOBJ = ../eispack/libeispack.a
+
+ ##--------------------------
+ # double precision (compile appropriate eispack and libPlt)
+-#DP = -fdefault-real-8
+-#PLTOBJ = ../plotlib/libPlt_gDP.a
+-#EIGOBJ = ../eispack/libeispackDP.a
++DP = -fdefault-real-8 -fdefault-double-8
++PLTOBJ = ../plotlib/libPlt_gDP.a
++EIGOBJ = ../eispack/libeispack_gDP.a
+ ##--------------------------
+
+ # use -m32 for 32-bit binary, -m64 for 64-bit (check your system!)
+@@ -110,7 +110,6 @@
+
+ avl: $(AOBJS)
+ $(FC) -o avl $(AOBJS) $(ALIBS) $(PLTOBJ) $(EIGOBJ) $(PLTLIB) $(FTNLIB) $(LFLG)
+- $(INSTALLCMD) avl $(BINDIR)
+
+ dtest: dtest.o
+ $(FC) -o dtest dtest.o $(LFLG)
+diff -ura avl.orig/eispack/Makefile.gfortran avl.new/eispack/Makefile.gfortran
+--- avl.orig/eispack/Makefile.gfortran 2014-05-22 09:51:00.000000000 -0700
++++ avl.new/eispack/Makefile.gfortran 2017-03-30 17:33:32.799291332 -0700
+@@ -7,8 +7,8 @@
+ DP =
+ EISLIB = libeispack.a
+
+-#DP = -fdefault-real-8
+-#EISLIB = eispack_gDP.a
++DP = -fdefault-real-8 -fdefault-double-8
++EISLIB = libeispack_gDP.a
+
+
+ $(EISLIB): eispack.f
+diff -ura avl.orig/plotlib/config.make.gfortranDP avl.new/plotlib/config.make.gfortranDP
+--- avl.orig/plotlib/config.make.gfortranDP 2017-02-12 11:20:53.000000000 -0800
++++ avl.new/plotlib/config.make.gfortranDP 2017-03-30 17:36:16.585592359 -0700
+@@ -28,11 +28,11 @@
+ # to gcc/gfortran to give a compatible binary 32 bit or 64 bit
+ # use -m32 for 32 bit binary, -m64 for 64 bit binary
+ MARCH =
+-#MARCH = -m64
++MARCH = -m64
+
+ # Fortran double precision (real) flag
+ DP =
+-DP = -fdefault-real-8
++DP = -fdefault-real-8 -fdefault-double-8
+
+ FFLAGS = -O2 $(MARCH) $(DP)
+ CFLAGS = -O2 $(MARCH) $(DEFINE)