summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Prussin2017-10-24 16:11:52 -0700
committerConnor Prussin2017-10-24 16:20:57 -0700
commit8516aa5b30c4cbdb6487a578019b5d5d63c6e328 (patch)
treecc8922f4c5bb89fff1a75eb3a737d194ae648517
downloadaur-8516aa5b30c4cbdb6487a578019b5d5d63c6e328.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD58
-rw-r--r--logrotate6
-rw-r--r--service11
5 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4894641efca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = avpnc
+ pkgdesc = Aviatrix VPN Client. Helps connect to VPN Networks. Supports SAML and password based authentication
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://docs.aviatrix.com/Downloads/samlclient.html
+ arch = any
+ license = custom
+ makedepends = imagemagick
+ depends = gedit>=2.0.0
+ depends = openvpn>=2.3.0
+ depends = zlib
+ depends = openresolv
+ options = !strip
+ options = emptydirs
+ source = https://s3-us-west-2.amazonaws.com/aviatrix-download/AviatrixVPNClient/dev/AVPNC_debian.deb
+ source = logrotate
+ source = service
+ sha512sums = 21fe71a81db93586caafb90a5736cfd222b109ea7170cda54e31aafdb7007f14108fd88a7de537c4feb85e4430ade4005109fb5982e2ff7e757beba44c309222
+ sha512sums = 4a64702faa88eda3150d8ad144a2359e55914f8041545ef0335990de5f546ae9b9eac00d56ebc8b4937077ad6d3694f66ce9c16014cc2f89b3a2dc599172569a
+ sha512sums = 1f47bbe3f6e37c5ce61fd94097fea19b46288e4fafd3aeccf30c37f710df8b7102c027d473be4dc7041451a507ce8ec74e10ab09c1ec4bf92c0bc2df1880a7e1
+
+pkgname = avpnc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f91991e0b44
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.pkg.tar.xz
+*.deb
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89620242a88a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Connor Prussin <connor at prussin dot net>
+
+# If you find problems with the package, create an issue on Github:
+# https://github.com/cprussin/avpnc
+
+pkgname=avpnc
+pkgver=1.5
+pkgrel=1
+pkgdesc="Aviatrix VPN Client. Helps connect to VPN Networks. Supports SAML and password based authentication"
+arch=('any')
+url='http://docs.aviatrix.com/Downloads/samlclient.html'
+license=('custom')
+depends=('gedit>=2.0.0' 'openvpn>=2.3.0' 'zlib' 'openresolv')
+makedepends=('imagemagick')
+options=(!strip emptydirs)
+source=(https://s3-us-west-2.amazonaws.com/aviatrix-download/AviatrixVPNClient/dev/AVPNC_debian.deb
+ logrotate
+ service)
+sha512sums=('21fe71a81db93586caafb90a5736cfd222b109ea7170cda54e31aafdb7007f14108fd88a7de537c4feb85e4430ade4005109fb5982e2ff7e757beba44c309222'
+ '4a64702faa88eda3150d8ad144a2359e55914f8041545ef0335990de5f546ae9b9eac00d56ebc8b4937077ad6d3694f66ce9c16014cc2f89b3a2dc599172569a'
+ '1f47bbe3f6e37c5ce61fd94097fea19b46288e4fafd3aeccf30c37f710df8b7102c027d473be4dc7041451a507ce8ec74e10ab09c1ec4bf92c0bc2df1880a7e1')
+
+package() {
+ bsdtar -xf ${srcdir}/data.tar.xz -C ${srcdir}/
+
+ # Install files to their correct locations (avpnc upstream has a really
+ # nonstandard structure)
+ install -Dm755 ${srcdir}/usr/bin/AVPNC_bin/AVPNC \
+ ${pkgdir}/usr/bin/${pkgname}
+ install -Dm755 ${srcdir}/usr/bin/AVPNC_bin/AVPNC_RP \
+ ${pkgdir}/usr/bin/${pkgname}_rp
+ install -Dm755 ${srcdir}/usr/bin/AVPNC_bin/scripts/linux.sh \
+ ${pkgdir}/usr/bin/${pkgname}_resolvconf
+ install -Dm644 ${srcdir}/usr/share/doc/avpnc/copyright \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 ${srcdir}/usr/bin/AVPNC_bin/AVPNC.desktop \
+ ${pkgdir}/usr/share/applications/${pkgname}.desktop
+
+ # Convert icon to correct size and install into correct location
+ mkdir -p ${pkgdir}/usr/share/icons/hicolor/128x128/apps
+ chmod 755 ${pkgdir}/usr/share/icons/hicolor/128x128/apps
+ convert -resize 128x128 ${srcdir}/usr/bin/AVPNC_bin/Avi.png \
+ ${pkgdir}/usr/share/icons/hicolor/128x128/apps/${pkgname}.png
+
+ # Update paths in desktop file
+ sed -e "s|/bin/AVPNC_bin/Avi.png|/share/icons/hicolor/128x128/apps/${pkgname}.png|" \
+ -e "s|AVPNC_bin/AVPNC|${pkgname}|" \
+ -e "s|Path=/usr/bin/AVPNC_bin|Path=/var/log/${pkgname}|" \
+ -i ${pkgdir}/usr/share/applications/${pkgname}.desktop
+
+ # Install log directory
+ mkdir -p ${pkgdir}/var/log/${pkgname}
+ chmod 755 ${pkgdir}/var/log/${pkgname}
+
+ # Install local scripts
+ install -Dm644 ../logrotate ${pkgdir}/etc/logrotate.d/${pkgname}
+ install -Dm644 ../service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
+}
diff --git a/logrotate b/logrotate
new file mode 100644
index 000000000000..7691a0564a39
--- /dev/null
+++ b/logrotate
@@ -0,0 +1,6 @@
+/var/log/avpnc/*log {
+ missingok
+ notifempty
+ compress
+ endscript
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..759861f9661b
--- /dev/null
+++ b/service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Aviatrix VPN Client. Helps connect to VPN Networks. Supports SAML and password based authentication
+After=network.target network-online.target nss-lookup.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/avpnc_rp
+WorkingDirectory=/var/log/avpnc
+
+[Install]
+WantedBy=multi-user.target