summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Nestler2018-10-15 23:53:54 +0200
committerRaphael Nestler2018-10-16 00:00:24 +0200
commit896c6fe67ef762a77e91a63c0e10ebe37f85f25b (patch)
treebff18bc18e9325a7b7603db1f0fd544bc6e8885a
downloadaur-avrdude-bobdude.tar.gz
Initial version, compatible with bobdude
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
-rw-r--r--libavrdude.pc11
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8d21c943cd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = avrdude-bobdude
+ pkgdesc = Download/upload/manipulate the ROM and EEPROM contents of AVR microcontrollers. Version which is compatible with bobdude
+ pkgver = 6.3
+ pkgrel = 1
+ url = http://www.nongnu.org/avrdude/
+ arch = x86_64
+ license = GPL
+ depends = readline
+ depends = libftdi
+ depends = libusb
+ provides = avrdude
+ conflicts = avrdude
+ conflicts = libftdi-compat
+ conflicts = libusb-compat
+ source = http://download.savannah.gnu.org/releases/avrdude/avrdude-6.3.tar.gz
+ source = http://download.savannah.gnu.org/releases/avrdude/avrdude-6.3.tar.gz.sig
+ source = libavrdude.pc
+ validpgpkeys = EF497ABE47ED91B3FC3D7EA54D902FF7723BDEE9
+ validpgpkeys = 5E84F980C3CAFD4BB5841070F48CA81B69A85873
+ validpgpkeys = F48CA81B69A85873
+ md5sums = 58bb42049122cf80fe4f4d0ce36d92ee
+ md5sums = SKIP
+ md5sums = 5db7bbff83f3b2490e4d3b7c52855071
+
+pkgname = avrdude-bobdude
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d05b93e43eb4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.tar.gz
+*.sig
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38c595940a80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: rnestler
+
+_pkgname=avrdude
+pkgname=avrdude-bobdude
+pkgver=6.3
+pkgrel=1
+pkgdesc="Download/upload/manipulate the ROM and EEPROM contents of AVR microcontrollers. Version which is compatible with bobdude"
+arch=('x86_64')
+url="http://www.nongnu.org/avrdude/"
+license=('GPL')
+depends=('readline' 'libftdi' 'libusb')
+provides=(avrdude)
+conflicts=(avrdude 'libftdi-compat' 'libusb-compat')
+source=(http://download.savannah.gnu.org/releases/avrdude/${_pkgname}-${pkgver}.tar.gz{,.sig}
+ libavrdude.pc)
+validpgpkeys=('EF497ABE47ED91B3FC3D7EA54D902FF7723BDEE9' '5E84F980C3CAFD4BB5841070F48CA81B69A85873' 'F48CA81B69A85873')
+md5sums=('58bb42049122cf80fe4f4d0ce36d92ee'
+ 'SKIP'
+ '5db7bbff83f3b2490e4d3b7c52855071')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ ./configure --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}/libavrdude.pc" "${pkgdir}/usr/lib/pkgconfig/libavrdude.pc"
+}
diff --git a/libavrdude.pc b/libavrdude.pc
new file mode 100644
index 000000000000..236aa19976f4
--- /dev/null
+++ b/libavrdude.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=/usr/bin
+libdir=/usr/lib
+includedir=/usr/include
+
+Name: libavrdude
+Description: Library to Download/upload/manipulate the ROM and EEPROM contents of AVR microcontrollers
+Requires: libusb-1.0 libftdi1
+Version: 1.4
+Libs: -L${libdir} -lavrdude
+Cflags: -I${includedir}