summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Lilienthal2018-09-24 14:30:05 -0400
committerNathan Lilienthal2018-09-24 14:30:05 -0400
commit688c58419bdbf3cdd83a1944222e4d06db4bf4c6 (patch)
tree90d11e9245a12b4eecd678801e94333df4bd1e60
downloadaur-688c58419bdbf3cdd83a1944222e4d06db4bf4c6.tar.gz
Initial build.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6274da1ea36e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = avrm-ds1307-git
+ pkgdesc = AVR library for the Maxim Intergrated DS1307.
+ pkgver = 0.0.3.r5.g4d73376
+ pkgrel = 1
+ url = https://github.com/nixpulvis/ds1307
+ arch = any
+ makedepends = git
+ depends = avrm
+ optdepends = avrdude: for flashing code to devices
+ provides = avrm-ds1307
+ conflicts = avrm-ds1307
+ options = !strip
+ source = git+https://github.com/nixpulvis/ds1307
+ md5sums = SKIP
+
+pkgname = avrm-ds1307-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f33cbfd391f8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.xz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfb0aa5aeecd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nathan Lilienthal <nathan@nixpulvis.com>
+pkgname=avrm-ds1307-git
+pkgver=0.0.3.r5.g4d73376
+pkgrel=1
+pkgdesc="AVR library for the Maxim Intergrated DS1307."
+arch=('any')
+url="https://github.com/nixpulvis/ds1307"
+depends=('avrm')
+optdepends=('avrdude: for flashing code to devices')
+makedepends=('git')
+provides=('avrm-ds1307')
+conflicts=('avrm-ds1307')
+options=('!strip')
+source=('git+https://github.com/nixpulvis/ds1307')
+md5sums=('SKIP')
+
+pkgver() {
+ T="${pkgname%-git}"
+ cd "$srcdir/${T#avrm-}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ T="${pkgname%-git}"
+ cd "$srcdir/${T#avrm-}"
+ make
+}
+
+package() {
+ T="${pkgname%-git}"
+ cd "$srcdir/${T#avrm-}"
+ make PREFIX="$pkgdir/usr/avr/" install
+}