summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Nelless2020-02-06 19:46:57 +0000
committerAndrew Nelless2020-02-06 19:46:57 +0000
commit04e6d2e4d7c56525c021d90ab198028298deff61 (patch)
tree58dd69f144d368b8577e28f56d61daf88e1fc33b
parent4c65e9c7759a00e0cc349ef8bc34b041463e3ca2 (diff)
downloadaur-04e6d2e4d7c56525c021d90ab198028298deff61.tar.gz
Bump to v1.9.2-rc1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1c4921d58e5..6e12cbdadec3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = avro-cpp
pkgdesc = C++ implementation of the Apache Avro data serialization system
- pkgver = 1.9.1
+ pkgver = 1.9.2_rc1
pkgrel = 1
url = https://avro.apache.org/
arch = i686
@@ -11,9 +11,9 @@ pkgbase = avro-cpp
makedepends = cmake
makedepends = python2
depends = boost-libs
- source = https://www-us.apache.org/dist/avro/avro-1.9.1/cpp/avro-cpp-1.9.1.tar.gz
+ source = https://github.com/apache/avro/archive/release-1.9.2-rc1.tar.gz
source = avro-cpp-python2.patch
- sha256sums = ff0c98f6f81294167677b221edcdd56b350fac523d857a5f53cf7fcd2187c683
+ sha256sums = 20c43ec8a0a4329caa875c35538b9b0faf60b6b0e6822c330b59a0ec83d11c73
sha256sums = 5d54151dd25e717a19109c97e68ce2a07d3b28b9fd3fb3ae1dc5df06b8600fd4
pkgname = avro-cpp
diff --git a/PKGBUILD b/PKGBUILD
index afb37a238fb3..44ae2a3b71a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrew Nelless <andrew at nelless dot net>
pkgname='avro-cpp'
-pkgver=1.9.1
+pkgver=1.9.2_rc1
pkgrel=1
arch=('i686' 'x86_64')
@@ -10,19 +10,22 @@ license=('Apache')
groups=('avro')
depends=('boost-libs')
makedepends=('boost' 'cmake' 'python2')
+_cppdir="avro-release-${pkgver//_/-}/lang/c++"
-source=("https://www-us.apache.org/dist/avro/avro-$pkgver/cpp/$pkgname-$pkgver.tar.gz"
+source=(
+ "https://github.com/apache/avro/archive/release-${pkgver//_/-}.tar.gz"
+# "https://www-us.apache.org/dist/avro/avro-$pkgver/cpp/$pkgname-$pkgver.tar.gz"
$pkgname-python2.patch)
-sha256sums=('ff0c98f6f81294167677b221edcdd56b350fac523d857a5f53cf7fcd2187c683'
+sha256sums=('20c43ec8a0a4329caa875c35538b9b0faf60b6b0e6822c330b59a0ec83d11c73'
'5d54151dd25e717a19109c97e68ce2a07d3b28b9fd3fb3ae1dc5df06b8600fd4')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_cppdir"
patch -p1 -i "$srcdir/$pkgname-python2.patch"
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_cppdir"
mkdir build
cd build
@@ -35,11 +38,11 @@ build() {
}
check() {
- cd "$srcdir/$pkgname-$pkgver/build"
+ cd "$srcdir/$_cppdir/build"
make test
}
package() {
- cd "$srcdir/$pkgname-$pkgver/build"
+ cd "$srcdir/$_cppdir/build"
make DESTDIR="$pkgdir/" install
}