summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-09-01 19:40:05 +0200
committerGoliathLabs2020-09-01 19:40:05 +0200
commit589c395074898e3fd99f87a9e030d583f3e68ec1 (patch)
treedf882e09331f09e2396c1713b14b2354f8729a71
parentff08eae38651cc350b118154b68a343bfc7c1f5b (diff)
downloadaur-avs-device-sdk.tar.gz
Updated: 1.20.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bb1ace71cdc..4d38db5273d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = avs-device-sdk
pkgdesc = SDK for commercial device makers to integrate Alexa directly into connected products
- pkgver = 1.19.1
+ pkgver = 1.20.1
pkgrel = 1
url = https://github.com/alexa/avs-device-sdk
arch = x86_64
@@ -12,8 +12,9 @@ pkgbase = avs-device-sdk
depends = gst-plugins-base-libs
depends = snowboy
depends = cblas
- source = avs-device-sdk-1.19.1.tar.gz::https://github.com/alexa/avs-device-sdk/archive/v1.19.1.tar.gz
- sha512sums = 96edaa1b78a582b9b9253e27f5f12c6be8415874ea8edb9e54f14e4e115eaff9bde5b99c2002a54fb1c26bb31dae9e89e9ad4642e743c7460f6628cec6c1f94e
+ depends = rapidjson
+ source = avs-device-sdk-1.20.1.tar.gz::https://github.com/alexa/avs-device-sdk/archive/v1.20.1.tar.gz
+ sha512sums = 1b1cde229918802b110d2bd6fc12552acb5ddb0a41a9792a9bcd7f469b88be103606d1ae30eaaa61f694b33eafb7c75ede2c2b35e394261b80a474f03191f0d1
pkgname = avs-device-sdk
diff --git a/PKGBUILD b/PKGBUILD
index 60bc01b99cac..28d07313f748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=avs-device-sdk
-pkgver=1.19.1
+pkgver=1.20.1
pkgrel=1
pkgdesc="SDK for commercial device makers to integrate Alexa directly into connected products"
arch=(x86_64 i686)
url="https://github.com/alexa/avs-device-sdk"
license=('Apache')
makedepends=('cmake')
-depends=('portaudio' 'gstreamer' 'gst-plugins-base-libs' 'snowboy' 'cblas')
+depends=('portaudio' 'gstreamer' 'gst-plugins-base-libs' 'snowboy' 'cblas' 'rapidjson')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/alexa/avs-device-sdk/archive/v${pkgver}.tar.gz")
-sha512sums=('96edaa1b78a582b9b9253e27f5f12c6be8415874ea8edb9e54f14e4e115eaff9bde5b99c2002a54fb1c26bb31dae9e89e9ad4642e743c7460f6628cec6c1f94e')
+sha512sums=('1b1cde229918802b110d2bd6fc12552acb5ddb0a41a9792a9bcd7f469b88be103606d1ae30eaaa61f694b33eafb7c75ede2c2b35e394261b80a474f03191f0d1')
prepare() {
sed -i 's/blas/cblas/' "${srcdir}/avs-device-sdk-${pkgver}/KWD/KittAi/src/CMakeLists.txt"
+ sed -i '/^add_subdirectory("rapidjson")/d' "${srcdir}/avs-device-sdk-${pkgver}/ThirdParty/CMakeLists.txt"
}
build() {