summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 15:51:55 +0200
committersl1pkn072015-06-08 15:51:55 +0200
commit34bd789c4a7fad3d24d375f909b1275cb521c818 (patch)
tree15c07faabc9857a3a0fbb3027a00c99197de6d27
downloadaur-34bd789c4a7fad3d24d375f909b1275cb521c818.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..089f40b5e8d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = avxsynth-plugin-decomb
+ pkgdesc = Plugin for Avxsynth: decomb
+ pkgver = 5.2.3
+ pkgrel = 2
+ url = http://mujintou.org.uk/avxsynth
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = yasm
+ makedepends = cmake
+ depends = avxsynth
+ provides = avxsynth-plugin-decomb
+ conflicts = avxsynth-plugin-decomb
+ source = http://mujintou.org.uk/projects/decomb.zip
+ md5sums = 27ce7941dd118d31d483f3a9503872c0
+
+pkgname = avxsynth-plugin-decomb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2827264efff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=decomb
+pkgname=avxsynth-plugin-decomb
+pkgver=5.2.3
+pkgrel=2
+pkgdesc="Plugin for Avxsynth: ${_plug}"
+arch=('i686' 'x86_64')
+url="http://mujintou.org.uk/avxsynth"
+license=('GPL')
+depends=('avxsynth')
+makedepends=('git' 'yasm' 'cmake')
+source=("http://mujintou.org.uk/projects/decomb.zip")
+md5sums=('27ce7941dd118d31d483f3a9503872c0')
+provides=("avxsynth-plugin-${_plug}")
+conflicts=("avxsynth-plugin-${_plug}")
+
+prepare() {
+ rm -fr build
+ cp -R "${_plug}" build
+}
+
+build() {
+ cd build
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr/lib/avxsynth -DCMAKE_ASM_NASM_COMPILER=yasm
+ make
+}
+
+package(){
+ cd build
+ install -Dm775 libdecomb.so "${pkgdir}/usr/lib/avxsynth/libdecomb.so"
+ install -Dm664 doc/DecombFAQ.html "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombFAQ.html"
+ install -Dm664 doc/DecombReferenceManual.html "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombReferenceManual.html"
+ install -Dm664 doc/DecombTutorial.html "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombTutorial.html"
+} \ No newline at end of file