summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-02-17 15:47:32 +0100
committersL1pKn072021-02-17 15:47:32 +0100
commitb45bfacee01647efb0af8d22fbb32b6dfbca4221 (patch)
tree795ea0da5e592e50d3c944f2d50e3751aaaa08dc
parent34bd789c4a7fad3d24d375f909b1275cb521c818 (diff)
downloadaur-b45bfacee01647efb0af8d22fbb32b6dfbca4221.tar.gz
update url
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 089f40b5e8d8..8468530e7264 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = avxsynth-plugin-decomb
pkgdesc = Plugin for Avxsynth: decomb
pkgver = 5.2.3
- pkgrel = 2
+ pkgrel = 3
url = http://mujintou.org.uk/avxsynth
arch = i686
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = avxsynth-plugin-decomb
makedepends = git
makedepends = yasm
makedepends = cmake
- depends = avxsynth
+ depends = avxsynth-git
provides = avxsynth-plugin-decomb
conflicts = avxsynth-plugin-decomb
- source = http://mujintou.org.uk/projects/decomb.zip
- md5sums = 27ce7941dd118d31d483f3a9503872c0
+ source = decomb.zip::https://www.dropbox.com/s/orv7x3qmfa8qwuv/decomb.zip?dl=0
+ sha256sums = 3c8efb8ea8c831c67c9af8ce9ccc7a0c18416ac75b1374181ced0708a68c36ba
pkgname = avxsynth-plugin-decomb
diff --git a/PKGBUILD b/PKGBUILD
index a2827264efff..7e5e9943f4ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,37 @@
_plug=decomb
pkgname=avxsynth-plugin-decomb
pkgver=5.2.3
-pkgrel=2
+pkgrel=3
pkgdesc="Plugin for Avxsynth: ${_plug}"
arch=('i686' 'x86_64')
-url="http://mujintou.org.uk/avxsynth"
+url='http://mujintou.org.uk/avxsynth'
license=('GPL')
-depends=('avxsynth')
-makedepends=('git' 'yasm' 'cmake')
-source=("http://mujintou.org.uk/projects/decomb.zip")
-md5sums=('27ce7941dd118d31d483f3a9503872c0')
+depends=('avxsynth-git')
+makedepends=('git'
+ 'yasm'
+ 'cmake'
+ )
+source=("decomb.zip::https://www.dropbox.com/s/orv7x3qmfa8qwuv/decomb.zip?dl=0")
+sha256sums=('3c8efb8ea8c831c67c9af8ce9ccc7a0c18416ac75b1374181ced0708a68c36ba')
provides=("avxsynth-plugin-${_plug}")
conflicts=("avxsynth-plugin-${_plug}")
prepare() {
- rm -fr build
- cp -R "${_plug}" build
+ mkdir -p build
}
build() {
cd build
- cmake . -DCMAKE_INSTALL_PREFIX=/usr/lib/avxsynth -DCMAKE_ASM_NASM_COMPILER=yasm
+ cmake ../decomb \
+ -DCMAKE_INSTALL_PREFIX=/usr/lib/avxsynth \
+ -DCMAKE_ASM_NASM_COMPILER=yasm
+
make
}
package(){
- cd build
- install -Dm775 libdecomb.so "${pkgdir}/usr/lib/avxsynth/libdecomb.so"
- install -Dm664 doc/DecombFAQ.html "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombFAQ.html"
- install -Dm664 doc/DecombReferenceManual.html "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombReferenceManual.html"
- install -Dm664 doc/DecombTutorial.html "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombTutorial.html"
-} \ No newline at end of file
+ install -Dm775 build/libdecomb.so "${pkgdir}/usr/lib/avxsynth/libdecomb.so"
+ install -Dm664 "${_plug}/doc/DecombFAQ.html" "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombFAQ.html"
+ install -Dm664 "${_plug}/doc/DecombReferenceManual.html" "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombReferenceManual.html"
+ install -Dm664 "${_plug}/doc/DecombTutorial.html" "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/DecombTutorial.html"
+}