summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 15:53:15 +0200
committersl1pkn072015-06-08 15:53:15 +0200
commit12a6f78dcf978d99498bbfd5ee14ba20d6c74850 (patch)
tree2748670fc60861ffe189722b399ca1ab2e87dfd8
downloadaur-12a6f78dcf978d99498bbfd5ee14ba20d6c74850.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21ef29c77ca7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = avxsynth-plugin-masktools2-git
+ pkgdesc = Plugin for Avxsynth. masktools2 (GIT Version)
+ pkgver = 20120620.d1028fd
+ pkgrel = 1
+ url = https://github.com/fundies/MaskTools2-linux
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = yasm
+ makedepends = boost
+ depends = avxsynth
+ provides = avxsynth-plugin-masktools2
+ conflicts = avxsynth-plugin-masktools2
+ source = masktools2::git://github.com/fundies/MaskTools2-linux.git
+ md5sums = SKIP
+
+pkgname = avxsynth-plugin-masktools2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7947c72dc2b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=masktools2
+pkgname=avxsynth-plugin-${_plug}-git
+pkgver=20120620.d1028fd
+pkgrel=1
+pkgdesc="Plugin for Avxsynth. ${_plug} (GIT Version)"
+arch=('i686' 'x86_64')
+url="https://github.com/fundies/MaskTools2-linux"
+license=('GPL')
+depends=('avxsynth')
+makedepends=('git' 'yasm' 'boost')
+provides=("avxsynth-plugin-${_plug}")
+conflicts=("avxsynth-plugin-${_plug}")
+
+source=("${_plug}::git://github.com/fundies/MaskTools2-linux.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+build() {
+ cd "${_gitname}"
+
+ LDFLAGS+=",-z,noexecstack"
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ install -Dm775 libmasktools.so "${pkgdir}/usr/lib/avxsynth/libmasktools.so"
+ install -Dm664 readme.txt "${pkgdir}/usr/share/doc/avxsynth/plugins/${_plug}/README"
+}
+