summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPayson Wallach2019-11-13 15:57:19 -0600
committerPayson Wallach2019-11-13 16:22:30 -0600
commit7a09d8176182958cbfedc5a9045ba574003f05be (patch)
treede37f00aa7d76710c96edfb674073b4e650770a8
downloadaur-7a09d8176182958cbfedc5a9045ba574003f05be.tar.gz
Initial commit
Add .gitignore
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b6180b0623f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aw-client
+ pkgdesc = Log what you do on your computer. Simple, extensible, no third parties.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/ActivityWatch/activitywatch
+ arch = i686
+ arch = x86_64
+ license = MPL2
+ makedepends = python>=3.5.1
+ makedepends = python-setuptools
+ depends = python>=3.5.1
+ depends = python-persist-queue
+ depends = python-requests
+ source = git+https://github.com/ActivityWatch/aw-client.git#commit=a8c9fd7
+ md5sums = SKIP
+
+pkgname = aw-client
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..560cf32f929d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Payson Wallach <payson@paysonwallach.com>
+
+pkgname=aw-client
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Log what you do on your computer. Simple, extensible, no third parties."
+arch=('i686' 'x86_64')
+url="https://github.com/ActivityWatch/activitywatch"
+license=('MPL2')
+groups=()
+depends=('python>=3.5.1' 'python-persist-queue' 'python-requests')
+makedepends=('python>=3.5.1' 'python-setuptools')
+source=("git+https://github.com/ActivityWatch/aw-client.git#commit=a8c9fd7")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}