summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPayson Wallach2019-11-13 15:59:24 -0600
committerPayson Wallach2019-11-13 16:23:32 -0600
commita9ce8c552f19c29387d289aee7d1d4c6417c7b71 (patch)
treec997319e042d099ccebf69d8e1fc68ef9c81aa93
downloadaur-a9ce8c552f19c29387d289aee7d1d4c6417c7b71.tar.gz
Initial commit
Add .gitignore
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56445c4cb155
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = aw-server
+ pkgdesc = Log what you do on your computer. Simple, extensible, no third parties.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/ActivityWatch/activitywatch
+ arch = i686
+ arch = x86_64
+ license = MPL2
+ makedepends = python>=3.5.1
+ makedepends = python-setuptools
+ depends = python>=3.5.1
+ depends = python-aniso8601
+ depends = python-appdirs
+ depends = python-attrs
+ depends = python-click
+ depends = python-flask-cors
+ depends = python-flask-restplus
+ depends = python-flask
+ depends = python-itsdangerous
+ depends = python-markupsafe
+ depends = python-jsonschema
+ depends = python-json-logger
+ depends = python-pyrsistent
+ depends = python-pytz
+ depends = python-werkzeug
+ source = git+https://github.com/ActivityWatch/aw-server.git#commit=9128018
+ md5sums = SKIP
+
+pkgname = aw-server
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acdefd56b4a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Payson Wallach <payson@paysonwallach.com>
+
+pkgname=aw-server
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Log what you do on your computer. Simple, extensible, no third parties."
+arch=('i686' 'x86_64')
+url="https://github.com/ActivityWatch/activitywatch"
+license=('MPL2')
+depends=('python>=3.5.1' 'python-aniso8601' 'python-appdirs' 'python-attrs' 'python-click' 'python-flask-cors' 'python-flask-restplus' 'python-flask' 'python-itsdangerous' 'python-markupsafe' 'python-jsonschema' 'python-json-logger' 'python-pyrsistent' 'python-pytz' 'python-werkzeug')
+makedepends=('python>=3.5.1' 'python-setuptools')
+source=("git+https://github.com/ActivityWatch/aw-server.git#commit=9128018")
+md5sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+ git submodule update --init --recursive
+ sed -i 's/=.*//' requirements.txt
+}
+
+build() {
+ cd $pkgname
+ make aw_webui
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}