summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2014-05-14 07:45:26 +0400
committerAnton Leontiev2015-02-15 07:48:21 +0300
commit38116fd1f2e4591deb12f616e3852488d664874f (patch)
treef84313f2c66f9cdae17fa59b25cb998e72460638
downloadaur-38116fd1f2e4591deb12f616e3852488d664874f.tar.gz
Adopted and updated to v0.3.5
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD30
-rw-r--r--awb.conf5
-rw-r--r--awb.install14
5 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4896058cc912
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = awb
+ pkgdesc = AsciiDoc Website Builder - build a website using AsciiDoc markup
+ pkgver = 0.3.5
+ pkgrel = 1
+ url = http://awb.sourceforge.net
+ install = awb.install
+ arch = any
+ license = GPL
+ depends = python
+ depends = asciidoc
+ noextract = awb-website.tar.bz2
+ source = http://sourceforge.net/projects/awb/files/awb/0.3.5/awb-0.3.5.tar.bz2/download
+ source = http://awb.sourceforge.net/awb-website.tar.bz2
+ source = awb.conf
+ md5sums = b7f9bf1195b69f7186fa17c683b8fe49
+ md5sums = e86f2250f14c44c62d26cbc7d8059db3
+ md5sums = d41ef48ff0f0dd585661eb6dec540c5e
+
+pkgname = awb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc2c475c5b18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: greg+devel@marvid.fr
+# Contributor: Jared Henley <multixrulz at users dot sourceforge dot net>
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+
+pkgname=awb
+pkgver=0.3.5
+pkgrel=1
+pkgdesc="AsciiDoc Website Builder - build a website using AsciiDoc markup"
+arch=('any')
+url='http://awb.sourceforge.net'
+license='GPL'
+depends=('python' 'asciidoc')
+install=awb.install
+source=(http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2/download
+ http://$pkgname.sourceforge.net/awb-website.tar.bz2
+ awb.conf)
+noextract=('awb-website.tar.bz2')
+
+md5sums=('b7f9bf1195b69f7186fa17c683b8fe49'
+ 'e86f2250f14c44c62d26cbc7d8059db3'
+ 'd41ef48ff0f0dd585661eb6dec540c5e')
+
+package() {
+ install -dm755 "$pkgdir/usr/share/awb/sample"
+ tar -xjf awb-website.tar.bz2 -C "$pkgdir/usr/share/awb/sample"
+ install -Dm645 awb.conf "$pkgdir/usr/share/awb/awb.conf"
+ cd $pkgname-$pkgver
+ install -Dm755 awb "$pkgdir/usr/bin/awb"
+ install -m644 ChangeLog "$pkgdir/usr/share/awb/ChangeLog"
+}
diff --git a/awb.conf b/awb.conf
new file mode 100644
index 000000000000..0e59b1f3761b
--- /dev/null
+++ b/awb.conf
@@ -0,0 +1,5 @@
+[sample]
+siteroot: /usr/share/awb/sample
+baseurl: http://example.com
+asciidoc options: -d book -b html4
+tidy: true
diff --git a/awb.install b/awb.install
new file mode 100644
index 000000000000..7af1f05167e8
--- /dev/null
+++ b/awb.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat << EOF
+A sample site is available in /usr/share/awb/sample
+It is entirely built with awb
+
+A default configuration file is also available in /usr/share/awb/awb.conf
+To start building your website with it, create ${XDG_CONFIG}/awb directory and copy awb.conf there, then make the changes that you find suitable.
+
+You might like to visit :
+ - http://awb.sourceforge.net/index.html
+ - http://www.methods.co.nz/asciidoc
+ - http://powerman.name/doc/asciidoc
+EOF
+}