summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLatif Sulistyo2022-03-30 16:37:50 +0700
committerLatif Sulistyo2022-03-30 16:37:50 +0700
commit04665ec70d2082c7a0059a33adbcf5894935af37 (patch)
tree56b2af8e1ff35a4cec3ca9778e86c47057c16760
downloadaur-awesome-layout-machi-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a8c8a53628b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = awesome-layout-machi-git
+ pkgdesc = AwesomeWM manual layout with an interactive editor
+ pkgver = r202.e413822
+ pkgrel = 1
+ url = https://github.com/xinhaoyuan/layout-machi
+ arch = any
+ license = Apache2.0
+ makedepends = git
+ depends = awesome
+ source = git+https://github.com/xinhaoyuan/layout-machi.git
+ md5sums = SKIP
+
+pkgname = awesome-layout-machi-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db9fabbb2403
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Latif Sulistyo <latifsulistyo.me@gmail.com>
+
+# shellcheck disable=2034,2154
+# shellcheck shell=bash
+
+_pkgname=layout-machi
+pkgname=awesome-$_pkgname-git
+pkgver=r202.e413822
+pkgrel=1
+pkgdesc='AwesomeWM manual layout with an interactive editor'
+
+arch=('any')
+url='https://github.com/xinhaoyuan/layout-machi'
+license=('Apache2.0')
+depends=('awesome')
+makedepends=('git')
+source=('git+https://github.com/xinhaoyuan/layout-machi.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname" || exit 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname" || exit 1
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+
+ find . \
+ -type f \
+ \( -iname '*.lua' -or -iname '*.patch' -or -iname 'icon.png' \) \
+ -exec install -Dm644 {} "$pkgdir/usr/share/awesome/lib/$_pkgname/{}" \;
+}