summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Hahler2020-10-07 13:31:50 +0200
committerDaniel Hahler2020-10-07 13:32:06 +0200
commit3e166d70ef9ae7f1b2bcdd73d6e7efed29d0dda2 (patch)
tree7e12aa4f28f9c048df1079413cfe29e50016a929
parent9f5d99ba7bf7c11084ac0cc946c48d6d0b16a3e1 (diff)
downloadaur-3e166d70ef9ae7f1b2bcdd73d6e7efed29d0dda2.tar.gz
Sort depends/makedepends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD31
2 files changed, 29 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12b56393b8cd..ac32d86bd2d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,12 +12,13 @@ pkgbase = awesome-luajit-git
makedepends = git
makedepends = imagemagick
makedepends = ldoc
- makedepends = xmlto
makedepends = lua-penlight
+ makedepends = xmlto
depends = cairo
depends = dbus
depends = gdk-pixbuf2
depends = libxdg-basedir
+ depends = libxfixes
depends = libxkbcommon-x11
depends = luajit
depends = luajit-lgi
@@ -25,9 +26,8 @@ pkgbase = awesome-luajit-git
depends = startup-notification
depends = xcb-util-cursor
depends = xcb-util-keysyms
- depends = xcb-util-xrm
depends = xcb-util-wm
- depends = libxfixes
+ depends = xcb-util-xrm
optdepends = rlwrap: readline support for awesome-client
optdepends = dex: autostart your desktop files
optdepends = vicious: widgets for the Awesome window manager
diff --git a/PKGBUILD b/PKGBUILD
index 3c9ffe1c838b..32708ed0d1b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,32 @@ pkgdesc="awesome window manager built with luajit"
arch=('i686' 'x86_64')
url='http://awesome.naquadah.org/'
license=('GPL2')
-depends=('cairo' 'dbus' 'gdk-pixbuf2' 'libxdg-basedir' 'libxkbcommon-x11'
- 'luajit' 'luajit-lgi' 'pango' 'startup-notification' 'xcb-util-cursor'
- 'xcb-util-keysyms' 'xcb-util-xrm' 'xcb-util-wm' 'libxfixes')
-makedepends=('asciidoc' 'cmake' 'docbook-xsl' 'git' 'imagemagick' 'ldoc'
- 'xmlto' 'lua-penlight')
+depends=(
+ 'cairo'
+ 'dbus'
+ 'gdk-pixbuf2'
+ 'libxdg-basedir'
+ 'libxfixes'
+ 'libxkbcommon-x11'
+ 'luajit'
+ 'luajit-lgi'
+ 'pango'
+ 'startup-notification'
+ 'xcb-util-cursor'
+ 'xcb-util-keysyms'
+ 'xcb-util-wm'
+ 'xcb-util-xrm'
+)
+makedepends=(
+ 'asciidoc'
+ 'cmake'
+ 'docbook-xsl'
+ 'git'
+ 'imagemagick'
+ 'ldoc'
+ 'lua-penlight'
+ 'xmlto'
+)
optdepends=('rlwrap: readline support for awesome-client'
'dex: autostart your desktop files'
'vicious: widgets for the Awesome window manager'