summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Tavares2022-04-25 15:44:18 +1000
committerFelipe Tavares2022-04-25 15:44:18 +1000
commit5a57fa274b7aa17f9840f8db95f3c64af53190d1 (patch)
tree7e1dd027e88ed6c40502ad07bd836ae41209f40a
downloadaur-5a57fa274b7aa17f9840f8db95f3c64af53190d1.tar.gz
initial commit
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD61
2 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bb1ed39604e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = awesome-git
+ pkgdesc = Highly configurable framework window manager; fixes telegram dead keys bug
+ pkgver = 4.3.1347.ga1f58ab97
+ pkgrel = 1
+ url = http://awesome.naquadah.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = asciidoctor
+ makedepends = cmake
+ makedepends = docbook-xsl
+ makedepends = git
+ makedepends = imagemagick
+ makedepends = ldoc
+ makedepends = xmlto
+ depends = cairo
+ depends = dbus
+ depends = gdk-pixbuf2
+ depends = libxdg-basedir
+ depends = libxkbcommon-x11
+ depends = lua
+ depends = lua-lgi
+ depends = pango
+ depends = startup-notification
+ depends = xcb-util-cursor
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = xcb-util-xrm
+ depends = libxfixes
+ optdepends = rlwrap: readline support for awesome-client
+ optdepends = dex: autostart your desktop files
+ optdepends = xcb-util-errors: for pretty-printing of X11 errors
+ optdepends = librsvg: for displaying SVG files without scaling artifacts
+ provides = notification-daemon
+ provides = awesome
+ conflicts = awesome
+ backup = etc/xdg/awesome/rc.lua
+ source = awesome-git::git+https://github.com/felipetavares/awesome.git
+ md5sums = SKIP
+
+pkgname = awesome-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d82234167742
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Felipe Tavares <felipe.oltavares+aur@gmail.com>
+# Contributor: Oleg Shparber <trollixx+aur@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Sébastien Luttringer
+# Contributor: xduugu
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Vesa Kaihlavirta
+# URL: https://github.com/trollixx/aur-packages
+# Upstream: https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/awesome
+
+_pkgname=awesome
+pkgname=${_pkgname}-git
+pkgver=4.3.1347.ga1f58ab97
+pkgrel=1
+pkgdesc='Highly configurable framework window manager; fixes telegram dead keys bug'
+arch=('i686' 'x86_64')
+url='http://awesome.naquadah.org/'
+license=('GPL2')
+depends=('cairo' 'dbus' 'gdk-pixbuf2' 'libxdg-basedir' 'libxkbcommon-x11'
+ 'lua' 'lua-lgi' 'pango' 'startup-notification' 'xcb-util-cursor'
+ 'xcb-util-keysyms' 'xcb-util-wm' 'xcb-util-xrm' 'libxfixes')
+makedepends=('asciidoctor' 'cmake' 'docbook-xsl' 'git' 'imagemagick' 'ldoc'
+ 'xmlto')
+optdepends=('rlwrap: readline support for awesome-client'
+ 'dex: autostart your desktop files'
+ 'xcb-util-errors: for pretty-printing of X11 errors'
+ 'librsvg: for displaying SVG files without scaling artifacts'
+)
+provides=('notification-daemon' 'awesome')
+conflicts=('awesome')
+backup=('etc/xdg/awesome/rc.lua')
+source=("$pkgname::git+https://github.com/felipetavares/awesome.git")
+md5sums=('SKIP')
+_LUA_VER=5.4
+
+pkgver() {
+ cd $pkgname
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ../$pkgname \
+ -DCMAKE_BUILD_TYPE=RELEASE \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSYSCONFDIR=/etc \
+ -DLUA_INCLUDE_DIR=/usr/include/lua${_LUA_VER} \
+ -DLUA_LIBRARY=/usr/lib/liblua.so.${_LUA_VER} \
+ -DLUA_EXECUTABLE=/usr/bin/lua${_LUA_VER}
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir"/$pkgname/awesome.desktop \
+ "$pkgdir/usr/share/xsessions/awesome.desktop"
+}