summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpzl2016-08-19 08:06:50 -0400
committerpzl2016-08-19 08:06:50 -0400
commitf87ece2841c1aa7ad5596f080276fb89fd2e46ec (patch)
treefcaab2f06fe99af8d9b15841cc118ff4002f6076
parentbc6688f4c6593c292e675457329f9c8d55ee6257 (diff)
downloadaur-f87ece2841c1aa7ad5596f080276fb89fd2e46ec.tar.gz
version bump to 5.0, use binary, chg maintainer
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD47
-rwxr-xr-xab.sh3
3 files changed, 44 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d92513f934a..bd750970c630 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri May 27 14:59:52 UTC 2016
+# Fri Aug 19 12:05:55 UTC 2016
pkgbase = awesomebump
pkgdesc = A free program designed to generate normal, height, specular or ambient occlusion textures from a single image
- pkgver = 4.0
+ pkgver = 5.0
pkgrel = 1
url = http://awesomebump.besaba.com/
arch = i686
@@ -10,9 +10,14 @@ pkgbase = awesomebump
license = LGPL3
makedepends = imagemagick
depends = qt5-base
- source = https://github.com/kmkolasinski/AwesomeBump/archive/Linuxv4.0.tar.gz
+ depends = qt5-location
+ depends = qt5-script
+ noextract = awesomebump.tar.gz
+ source = awesomebump.tar.gz::https://github.com/kmkolasinski/AwesomeBump/releases/download/Linuxv5.0/AwesomeBumpV5.Bin64Linux.tar.gz
+ source = ab.sh
source = awesomebump.desktop
- md5sums = 7fa501fb9e18dc72d220472c12ae5cf4
+ md5sums = ddd4f676570575b78a3f2612369ba186
+ md5sums = 462c8edb251cb603d78242b14189e354
md5sums = a798a1946042f5c06505043100a32e28
pkgname = awesomebump
diff --git a/PKGBUILD b/PKGBUILD
index b8057d95c417..83dd20746144 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,51 @@
# Maintainer: Dan Panzarella <alsoelp@gmail.com>
pkgname=awesomebump
-pkgver=4.0
+pkgver=5.0
pkgrel=1
pkgdesc="A free program designed to generate normal, height, specular or ambient occlusion textures from a single image"
arch=('i686' 'x86_64')
url="http://awesomebump.besaba.com/"
license=('LGPL3')
-depends=('qt5-base')
+depends=('qt5-base' 'qt5-location' 'qt5-script')
makedepends=('imagemagick')
-source=("https://github.com/kmkolasinski/AwesomeBump/archive/Linuxv${pkgver}.tar.gz"
+source=("${pkgname}.tar.gz::https://github.com/kmkolasinski/AwesomeBump/releases/download/Linuxv${pkgver}/AwesomeBumpV5.Bin64Linux.tar.gz"
+ "ab.sh"
"awesomebump.desktop")
-md5sums=('7fa501fb9e18dc72d220472c12ae5cf4'
+md5sums=('ddd4f676570575b78a3f2612369ba186'
+ '462c8edb251cb603d78242b14189e354'
'a798a1946042f5c06505043100a32e28')
+noextract=("${pkgname}.tar.gz") #because it doesn't expand into a subdir
-build() {
- cd "${srcdir}/AwesomeBump-Linuxv${pkgver}/Sources"
- qmake-qt5 -config release
- make
+# Extract tar into a subdir to not pollute source directory which contains
+# symlinks to our provided files, causing annoyances on copy
+prepare() {
+ cd "${srcdir}"
+ mkdir "${pkgname}-src"
+ tar -xzf "${pkgname}.tar.gz" -C "${pkgname}-src"
}
package() {
- cd "${srcdir}/AwesomeBump-Linuxv${pkgver}"
+ cd "${srcdir}"
+ install -dm755 "${pkgdir}/opt"
- install -Dm755 "Sources/AwesomeBump" "${pkgdir}/opt/awesomebump/AwesomeBump"
- install -d "${pkgdir}/usr/bin"
- ln -s "/opt/awesomebump/AwesomeBump" "${pkgdir}/usr/bin/AwesomeBump"
- cp -r "Bin/Configs" "Bin/Core" "${pkgdir}/opt/awesomebump"
- convert Sources/icon.ico awesomebump.png
+ cp --preserve=mode -r "${pkgname}-src" "${pkgdir}/opt/awesomebump"
+
+ convert "${pkgname}-src/logo.ico" awesomebump.png
install -Dm644 "awesomebump.png" "${pkgdir}/usr/share/pixmaps/awesomebump.png"
- install -Dm644 "${srcdir}/awesomebump.desktop" "${pkgdir}/usr/share/applications/awesomebump.desktop"
+ install -Dm644 "awesomebump.desktop" "${pkgdir}/usr/share/applications/awesomebump.desktop"
+ install -Dm755 "ab.sh" "${pkgdir}/usr/bin/AwesomeBump"
+
}
+
+# Compiling this project from source has been a nightmare
+# that I have been unable to complete. Running the binary is possible
+# but it is VERY finicky with paths. Just symlinking to /usr/bin
+# (either the binary or the RunAB script) both complain because the
+# texture and config paths are in /opt and it is using relative
+# references internally. I caved and just made my own run script to move
+# a subshell over there and run it.
+
+# Project author is discontinuing work on AB, so filing upstream issues
+# to fix these path problems is a no-go.
diff --git a/ab.sh b/ab.sh
new file mode 100755
index 000000000000..7666f9af1a25
--- /dev/null
+++ b/ab.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+cd /opt/awesomebump && ./RunAwesomeBump.sh